[GE users] Error installing 6.0beta2 master

Orion Poplawski orion at cora.nwra.com
Fri Apr 23 23:23:47 BST 2004


during ./inst_sge -m:


Grid Engine qmaster and scheduler startup
-----------------------------------------

Starting qmaster and scheduler daemon. Please wait ...
    starting sge_qmaster
usage: qping [-i <interval>] [-info] [-f] <host> <port> <name> <id>
    -i    : set ping interval time
    -info : show full status information and exit
    -f    : show full status information on each ping interval
usage: qping [-i <interval>] [-info] [-f] <host> <port> <name> <id>
    -i    : set ping interval time
    -info : show full status information and exit
    -f    : show full status information on each ping interval
usage: qping [-i <interval>] [-info] [-f] <host> <port> <name> <id>
    -i    : set ping interval time
    -info : show full status information and exit
    -f    : show full status information on each ping interval

this repeated until I stopped it.

Looks like the script tries to run:

       $bin_dir/qping -info $masterhost $SGE_QMASTER_PORT qmaster 1 > 
/dev/null

but SGE_QMASTER_PORT is not set, so it runs:

/opt/local/sge-6.0/bin/lx24-x86/qping -info 
cynosure.colorado-research.com qmaster 1

I had defined the sge_qmaster port in /etc/services as 701.

Where is the init script supposed to get SGE_QMASTER_PORT from?

I decided to add:

SGE_QMASTER_PORT=sge_qmaster; export SGE_QMASTER_PORT

to the script.  This caused qping to run, but it never returned success.

It looks like sge_qmaster had started, but that is was listening on the 
wrong port:

sge_qmast 6037 sgeadmin    3u  IPv4 2268940             TCP *:42729 (LISTEN)

Setting SGE_QMASTER_PORT to 701 solved the problem, so it looks like 
sge_qmaster is looking up the port wrong - probably not using network 
byte order?


-- 
Orion Poplawski
System Administrator                   303-415-9701 x222
Colorado Research Associates/NWRA      FAX: 303-415-9702
3380 Mitchell Lane, Boulder CO 80301   http://www.co-ra.com

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list