[GE users] Strange behaviour with '-sync y' (6.0u6)

Reuti reuti at staff.uni-marburg.de
Wed Dec 14 13:01:57 GMT 2005


Hi,

do you have "-w w" somewhere as default request? - Reuti

Am 14.12.2005 um 13:41 schrieb Olesen, Mark:

> Hi,
> I am encountering some strange, or at least non-intuitive,  
> behaviour when
> using the '-sync y' option.
>
> I expected submitting with '-sync y' and '-now n' (implicitly or  
> explicitly)
> would cause the qsub to block until the job can run.
>
> Assuming that I request many more licenses than I have
> $ qsub -sync y -l gtpower=10 ...
>
> Unable to run job: warning: no suitable queues
> your job 17820 ("gtpower -d db -m off -x 65406 -c 1-4 4cyl") has been
> submitted.
> Exiting.
>
>
> Fiddling with '-now y|n' seems to have no effect.
> Interestingly enough, even if I want to start my job sometime in  
> the future:
>
> $ qsub -sync y -now y -l gtpower=10 -a 12241200 ...
>
> It exhibits the same behaviour.
> The behaviour would look like '-now y' is always being specified.
> I don't remember this sort of behaviour with 6.0u4 ... have I  
> discovered a
> bug?
>
> Does anyone have a clever workaround?
>
> /mark
>
> Dr. Mark Olesen
> Principal Engineer Thermofluids Analysis
> ArvinMeritor Light Vehicle Systems
> ArvinMeritor Emissions Technologies GmbH
> Biberbachstr. 9
> D-86154 Augsburg, GERMANY
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> For additional commands, e-mail: users-help at gridengine.sunsource.net


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list