[GE users] sge 6.0u7 for OS X 10.4 (aka Darwin 8.3.0)?

Chris Dagdigian dag at sonsorol.org
Wed Dec 14 13:58:19 GMT 2005



There are two main reasons why I usually end up building SGE from  
source on OS X. Both are minor but both occasionally catch me during  
misc. projects:

  (1) The versions of libcrypto.dylib and libssl.dylib installed in  
$SGE_ROOT/utilbin/darwin/  are sometimes incompatible with what is  
installed on OS X. Since the settings.sh scripts set  
DYLD_LIBRARY_PATH to point to this location, a common symptom is that  
Grid Engine will break SSH cluster-wide as all connections fail with  
"library version mismatch errors". The solution for me when using  
courtesy binaries has been to blow these libraries out of the SGE  
distribution since I don't operate in "secure" mode.  Building from  
source removes this glitch.

(2) 'qmon' almost never works with courtesy binaries on OS X because  
I always have a more modern or less current version of Motif  
installed. When using courtesy binaries I can build or reinstall the  
proper version of openmotif. When building from source, it "just  
works" with whatever motif I've already built.

-Chris


On Dec 13, 2005, at 6:01 PM, Rayson Ho wrote:

> The pre-compiled binary should work on both 10.3 and 10.4...
>
> Rayson
>
>
>
> On 12/13/05, Ivan R. Judson <judson at mcs.anl.gov> wrote:
>>
>> Anybody compiled this for Tiger?
>>
>> --Ivan
>>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list