[GE users] Open MPI and SGE

Rayson Ho rayrayson at gmail.com
Thu Apr 27 05:20:06 BST 2006


    [ The following text is in the "ISO-8859-1" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]

Since it was execv(2) that failed, it seems to me that it was trying
to execute something which was not there...

May be you can add some debug echo in the scripts to see what gets
passed to rsh/qrsh.

Rayson



On 4/27/06, Bernard Li <bli at bcgsc.ca> wrote:
> Thanks Rayson.
>
> But I wonder what it could be...  the machine file is there, the scripts
> are there, the pe_hostfile is there...  some times I wish these error
> messages are more descriptive :-)
>
> Cheers,
>
> Bernard
>
> > -----Original Message-----
> > From: Rayson Ho [mailto:rayrayson at gmail.com]
> > Sent: Wednesday, April 26, 2006 20:24
> > To: users at gridengine.sunsource.net
> > Subject: Re: [GE users] Open MPI and SGE
> >
> > Hmm... errno = 2:
> >
> > /usr/include/asm-generic/errno-base.h
> > #define ENOENT           2      /* No such file or directory */
> >
> > Rayson
> >
> >
> > On 4/26/06, Bernard Li <bli at bcgsc.ca> wrote:
> > > Has anybody been successful with getting Open MPI
> > integrated with SGE (I
> > > think Reuti has ;-) ).
> > >
> > > Anyways, I think I'm pretty close, but I'm stuck with this issue:
> > >
> > > [node1:28248] pls:rsh: execv failed with errno=2
> > >
> > > Anybody knows what it means?
> > >
> > > I basically set it up like Reuti recommended in the following email:
> > >
> > >
> > http://gridengine.sunsource.net/servlets/ReadMsg?list=users&ms
> > gNo=15176
> > >
> > > My template looks like this:
> > >
> > > pe_name           openmpi
> > > slots             999
> > > user_lists        NONE
> > > xuser_lists       NONE
> > > start_proc_args   /opt/sge/mpi/startmpi.sh $pe_hostfile
> > > stop_proc_args    /opt/sge/mpi/stopmpi.sh
> > > allocation_rule   $round_robin
> > > control_slaves    FALSE
> > > job_is_first_task TRUE
> > > urgency_slots     min
> > >
> > > It might be helpful to post a working integration in the
> > SGE website.
> > >
> > > Thanks!
> > >
> > > Bernard
> > >
> > >
> > ---------------------------------------------------------------------
> > > To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> > > For additional commands, e-mail: users-help at gridengine.sunsource.net
> > >
> > >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> > For additional commands, e-mail: users-help at gridengine.sunsource.net
> >
> >
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> For additional commands, e-mail: users-help at gridengine.sunsource.net
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list