[GE users] qmon segfault

V01D phreakuencies at gmail.com
Thu Aug 10 22:51:21 BST 2006


    [ The following text is in the "ISO-8859-1" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]

Hi,
I've build gridengine 6.0u8 and qmon segfaults:

(gdb) run
Starting program: /opt/gridengine/bin/lx26-x86/qmon
[Thread debugging using libthread_db enabled]
[New Thread -1213007680 (LWP 2549)]
[New Thread -1213052000 (LWP 2552)]
[New Thread -1221444704 (LWP 2553)]
[New Thread -1229837408 (LWP 2554)]
[New Thread -1238230112 (LWP 2555)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1213007680 (LWP 2549)]
0xb7cf101b in XTextWidth () from /usr/lib/libX11.so.6
(gdb) bt
#0  0xb7cf101b in XTextWidth () from /usr/lib/libX11.so.6
#1  0x0814ea78 in Initialize (request=0xbfc9b978, init=0x8429990, args=0x0,
     num_args=0xbfc9b944) at ../Xmt310/Xmt/Layout.c:500
#2  0xb7ddc678 in CallInitialize () from /usr/lib/libXt.so.6
#3  0xb7ddd0eb in xtCreate () from /usr/lib/libXt.so.6
#4  0xb7ddd9af in _XtCreateWidget () from /usr/lib/libXt.so.6
#5  0xb7dddd50 in XtCreateWidget () from /usr/lib/libXt.so.6
#6  0x0814d28e in XmtCreateLayout (parent=0x84261f8, name=0x84267a8 
"cq", args=0x0, n=0)
     at ../Xmt310/Xmt/Layout.c:2171
#7  0x0815f559 in XmtCreateWidgetType (name=0x84267a8 "cq", type=0x84261f8,
     parent=0x84261f8, args=0x0, num_args=3) at 
../Xmt310/Xmt/WidgetType.c:238
#8  0x0814359a in CreateChild (parent=0x84261f8, name=0x84267a8 "cq", 
type=0x82d7bb8,
     template=0x0, managed=1 '\001', styles=0x0, num_styles=0, load=1 
'\001',
     dialog_info=0x8426740, names=0x8425f88, num_names=25) at 
../Xmt310/Xmt/Create.c:182
#9  0x08143ca6 in CreateChildren (parent=0x84261f8, dialog_info=0x8426740,
     names=0x8425f88, num_names=25) at ../Xmt310/Xmt/Create.c:454
#10 0x081442c2 in XmtBuildQueryDialog (parent=0x83a9bb8,
     dialog_name=0x82514e0 "qmon_cq", resources=0x0, num_resources=0)
     at ../Xmt310/Xmt/Create.c:573
#11 0x080c260a in qmonCQPopup (w=0x841f1e0, cld=0x0, cad=0xbfc9c0f0)
     at ../clients/qmon/qmon_cq.c:268
#12 0xb7dd4763 in XtCallCallbackList () from /usr/lib/libXt.so.6
#13 0xb7ed1b32 in Activate () from /usr/lib/libXm.so.2
---Type <return> to continue, or q <return> to quit---q

I run into another problem while compiling gridengine regarding the 
NeedWidePrototypes flag. I was getting some errors regarding 
incompatible function prototypes. I fixed that by replacing any #ifdef 
NeedWidePrototypes with #ifdef _NeedWidePrototypes, since I couldn't get 
it to compile any other way. Don't know if that's related to the 
previous segfault.

Thank you,
Matt.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list