[GE users] creating a Master queue

Lönroth Erik erik.lonroth at scania.com
Tue May 29 16:10:16 BST 2007


    [ The following text is in the "iso-8859-1" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]

It seemed to work better, I seem to need some reading on that "job_is_first_task" thing, but now I only get 7 SLAVES, do I need to specify N+1 "pe slots" then, or is there some other way you would normally do this?

    348 0.55500 powerflow_ sssler       r     05/29/2007 17:02:56 master.103.q at ts103-3-0.sss.se. MASTER                
    348 0.55500 powerflow_ sssler       r     05/29/2007 17:02:56 short.103.q at ts103-3-0.sss.se.s SLAVE         
                                                                  short.103.q at ts103-3-0.sss.se.s SLAVE         
                                                                  short.103.q at ts103-3-0.sss.se.s SLAVE         
    348 0.55500 powerflow_ sssler       r     05/29/2007 17:02:56 short.103.q at ts103-3-22.sss.se. SLAVE         
                                                                  short.103.q at ts103-3-22.sss.se. SLAVE         
                                                                  short.103.q at ts103-3-22.sss.se. SLAVE         
                                                                  short.103.q at ts103-3-22.sss.se. SLAVE         



/Erik

-----Original Message-----
From: Reuti [mailto:reuti at staff.uni-marburg.de] 
Sent: den 29 maj 2007 16:54
To: users at gridengine.sunsource.net
Subject: Re: [GE users] creating a Master queue


Am 29.05.2007 um 16:19 schrieb Lönroth Erik:

> As you see:
> master.102.q at ts102-2-0.sss.se. MASTER master.102.q at ts102-2-0.sss.se. 
> SLAVE
>
> ... Which is not what I want.
>
> I have set number os slots to "1" in the master queue, and number
> of processors to "1", with no luck.

The processors should be left to "UNDEFINED", unless you are on IRIX.

What is the setting of "job_is_first_task" in your PE setting? It  
should be set to "TRUE" in your case.

-- Reuti

>
>
> Any help or ideas?
>
> /Erik
>
>
>
> -----Original Message-----
> From: Reuti [mailto:reuti at staff.uni-marburg.de]
> Sent: den 28 maj 2007 21:55
> To: users at gridengine.sunsource.net
> Subject: Re: [GE users] creating a Master queue
>
>
> Hi,
>
> Am 28.05.2007 um 21:19 schrieb Milo:
>
>> I have, but I'm still confused as to how exactly it works. Thus far 
>> when I haven't explicitly specified the master queue using the 
>> -masterq argument,
>> SGE obviously uses my only queue (all.q) for both master and slave.
>> I've
>> also noticed that the master node still gets a slave process
>> assigned to it.
>> Will this slave process still get spawned on the master queue if I
>> use the
>> -masterq argument to qsub?
>
> yes - might happen, if there are still free slots.
>
>> If so, do I have the ability to control this? I
>> also don't exactly know how to actually create this new master queue 
>> with the correct settings and such. Could someone point me in the 
>> right direction?
>
> Just this morning, maybe it's still in your inbox:
>
> http://gridengine.sunsource.net/servlets/ReadMsg?
> list=users&msgNo=20022
>
> -- Reuti
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> For additional commands, e-mail: users-help at gridengine.sunsource.net
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> For additional commands, e-mail: users-help at gridengine.sunsource.net
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list