[GE users] New grid problems

Robert White alphamonk at gmail.com
Sat Jan 26 00:29:33 GMT 2008


    [ The following text is in the "ISO-8859-1" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]

Hi All,

I have a job script that runs correctly when I run the application from the
command line on a execution host without sending the app through SGE. If I
run the job through grid either using qrsh, qsub or qlogin, I receive the
same error. The error complains about a library file that. This is the error
message. "libdenpli.so: failed cannot open shared object file: No such file
or directory or file is not valid ELFCLASS32 library"

When I run the command on an execution host and use strace to see if find
this library this is what I see.
open("/tools/denali/denali_3.2.050/verilog/libdenpli.so", O_RDONLY) = 10
read(10, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\300\275"..., 512)
= 512
fstat64(10, {st_mode=S_IFREG|0755, st_size=19806385, ...}) = 0
old_mmap(NULL, 27237300, PROT_READ|PROT_EXEC, MAP_PRIVATE, 10, 0) =
0x32fae000
old_mmap(0x33fc4000, 1052672, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED,
10, 0x1015000) = 0x33fc4000
old_mmap(0x340c5000, 9317300, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x340c5000
close(10)                               = 0


When I do a qlogin and ran the command by hand using strace and found this
at the point where the library file is being accessed.
open("/tools/denali/denali_3.2.050/verilog/libdenpli.so", O_RDONLY) = 10
read(10, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\300\275"..., 512)
= 512
fstat64(10, {st_mode=S_IFREG|0755, st_size=19806385, ...}) = 0
old_mmap(NULL, 27237300, PROT_READ|PROT_EXEC, MAP_PRIVATE, 10, 0) = -1
ENOMEM (Cannot allocate memory)
close(10)                               = 0

Does anyone know what this problem could be? Are there any memory
limitations that I have someone that I am not aware of. This is a new
install of SGE 6.1u2 running on RHEL3.9 computers.

Thanks Bob



More information about the gridengine-users mailing list