[GE users] Testing 6.2 beta

Daniel Templeton Dan.Templeton at Sun.COM
Tue Jun 3 21:34:05 BST 2008


    [ The following text is in the "ISO-8859-1" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]

You can't.  Interactive jobs are submitted with qrsh, qsh, qlogin, or qtcsh.

Daniel

Alexandre Racine wrote:
> Eerrr... how can I use qsub to submit an interactive job? :)
> The man qsub is from March :)
>
> Thanks.
>
>
>
> Alexandre Racine
> alexandre.racine at mhicc.org
> 514-461-1300 poste 3303
>
>   
>> -----Original Message-----
>> From: Olesen, Mark [mailto:Mark.Olesen at emcontechnologies.com]
>> Sent: 2 juin 2008 04:02
>> To: GridEngine
>> Subject: [GE users] Testing 6.2 beta
>>
>> I admittedly didn't read (or find) anything about upgrading from 6.1X
>> to
>> 6.2beta, but never had problems in the past ...
>>
>> I am trying 6.2beta lx24-x86 on a mixed i686 / x86_64 environment with
>> mostly SuSE 10.2 (a few 10.3 as well).
>>
>> Are there any particular format changes in the configuration files
>>     
> that
>   
>> I need to account for? My first trial of 6.2beta looks really, really
>> bad!
>>
>> Since I have my init-script (starts qmaster and/or execd
>> automatically),
>> I always skip using the supplied installation script and instead
>>     
> simply
>   
>> create new soft-links to the directory. My 'default' and
>> 'default/common' directories are stored on an NFS mount that I also
>> link
>> in appropriately.
>>
>> 1) qconf -ke all
>> 2) qconf -ks
>> 3) qconf -km
>> manual kill shadowd (since I don't remember any other way).
>>
>> Edited my rc.d/ script to avoid error messages with the now defunct
>> schedd. Eg,
>>
>>   # pre 6.2 had scheduler daemon
>>   if [ -f $bin_dir/sge_schedd ]; then
>>      StartDaemon "scheduler" $bin_dir/sge_schedd  $SGE_SCHEDD_ARGS
>>   fi
>>
>>
>> Change directory soft-links etc (as described above) and use init-
>> script
>> with 'restart'.  Since I am using traditional spooling, there is not
>> Berkley db to worry about.
>>
>> My first Hello World job script:
>>
>> $ qsub
>> echo hallo
>> ^D
>>
>>
>> Unable to run job: warning: olesenm your job is not allowed to run in
>> any queue
>> Your job 60209 ("STDIN") has been submitted.
>>
>>
>> The 2nd Hello World job script:
>>
>> $ qsub -q desk
>> echo okay
>> ^D
>>
>> Unable to run job: Job was rejected because job requests unknown queue
>> "desk".
>> Exiting.
>>
>>
>> The output of 'qconf -sq desk' is correct, and the associated host
>> group
>> 'qconf -shgrp @desk' also looks fine. The gethostbyname also returns
>> the
>> correct values.
>>
>> The following is *very* interesting:
>>
>> qhost -q shows the hosts, but without a single queue.
>> qstat -f and qstat -F only show my pending jobs, but no other output:
>>
>> ####################################################################
>>  - PENDING JOBS - PENDING JOBS - PENDING JOBS - PENDING JOBS
>> ####################################################################
>>   60207 0.00000 STDIN      olesenm      qw    06/02/2008 09:36:38
>>     
> 1
>   
>>   60208 0.00000 STDIN      olesenm      qw    06/02/2008 09:37:01
>>     
> 1
>   
>>   60209 0.00000 STDIN      olesenm      qw    06/02/2008 09:37:21
>>     
> 1
>   
>> Checking the output of 'qconf -sc' and 'qconf -se global' shows the
>> complexes are indeed configured.
>>
>> What is going wrong here?
>>
>> /mark
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
>> For additional commands, e-mail: users-help at gridengine.sunsource.net
>>     
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> For additional commands, e-mail: users-help at gridengine.sunsource.net
>
>   

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list