[GE users] Problems with PEs and resource quotas

mdsteeves mdsteeves at gmail.com
Tue Dec 14 21:13:31 GMT 2010


On 12/14/10 3:34 PM, reuti wrote:
> Am 14.12.2010 um 21:02 schrieb mdsteeves:
>> Resource reservation for the resource quota piece? We don't use that at
>> the moment -- the moe_limit that's currently in place limits each user
>> to only be able to have 20 jobs running, which is the behavior that we
>> want. The problem we're having is that other jobs, that don't need or
>> use these licenses, get stuck in a "qw" state, and reference the
>> moe_limit resource quota. If we go in and disable the resource quota,
>> then the job gets dispatched to a node and runs without problem.
>
> AFAICS you are limiting the number of potential queue instances with all the examples you mentioned as not working:
>
> ## #$ -l q=mpi.q
> ## #$ -l hostname="compute-0-2"
> ## #$ -l hostname...
>
> Hence SGE has less options to schedule the job. Or does it also happen in an empty cluster?
>
> Nevertheless: One bug to mention is, that you can't use -q in combination with -l h=. The workaround is to request the hostnames in the -q request:
>
> -q mpi.q at compute-0-2


We're working with the user to see what they're trying to accomplish 
with the resource requests, but we're also trying to figure out why the 
moe_limit is causing these jobs to sit in qw when enabled.


-Mike
-- 
Michael Steeves (mdsteeves at gmail.com)

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=305595

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list