[GE users] 6.2u5 memory reporting issue - building ge

coffman michael.coffman at avagotech.com
Mon Dec 20 18:49:29 GMT 2010


    [ The following text is in the "iso-8859-1" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]


Thanks for the reply..

On Mon, Dec 20, 2010 at 11:17 AM, Daniel Templeton <daniel.templeton at oracle.com<mailto:daniel.templeton at oracle.com>> wrote:
Did you run:

No.

aimk -only-depend
scripts/zerodepend
aimk depend


aimk depend fails with:

cd .. && /bin/sh builddir/sge/svn/gridscheduler/source/3rdparty/plpa/plpa-1.3.1/config/missing --run automake-1.10 --foreign
builddir/sge/svn/gridscheduler/source/3rdparty/plpa/plpa-1.3.1/config/missing: line 54: automake-1.10: command not found
WARNING: `automake-1.10' is missing on your system.  You should only need it if
         you modified `Makefile.am', `acinclude.m4' or `configure.ac<http://configure.ac>'.
         You might want to install the `Automake' and `Perl' packages.
         Grab them from any GNU archive site.
cd .. && /bin/sh builddir/sge/svn/gridscheduler/source/3rdparty/plpa/plpa-1.3.1/config/missing --run autoconf
aclocal.m4:20: warning: this file was generated for autoconf 2.63.
You have another version of autoconf.  It may work, but is not guaranteed to.
If you have problems, you may need to regenerate the build system entirely.
To do so, use the procedure documented by the package, typically `autoreconf'.
configure.ac:24<http://configure.ac:24>: error: Autoconf version 2.59 or higher is required
configure.ac:24<http://configure.ac:24>: the top level
autom4te: /usr/bin/m4 failed with exit status: 1
make: *** [../configure] Error 1


$ rpm -q automake
automake-1.9.6-2.1

Now tried just running

aimk

And get:

aclocal.m4:20: warning: this file was generated for autoconf 2.63.
You have another version of autoconf.  It may work, but is not guaranteed to.
If you have problems, you may need to regenerate the build system entirely.
To do so, use the procedure documented by the package, typically `autoreconf'.
configure.ac:24<http://configure.ac:24>: error: Autoconf version 2.59 or higher is required
configure.ac:24<http://configure.ac:24>: the top level
autom4te: /usr/bin/m4 failed with exit status: 1

I don't see how to run autoreconf...

Daniel


On 12/20/10 10:15 AM, coffman wrote:
Hello all,

I am trying to build O|SGE so I can drop in a version of execd that will
properly report memory usage.   After reading several threads related to
this, it seemed that is what I would need to do.   I have downloaded the
source via:

svn co https://gridscheduler.svn.sourceforge.net/svnroot/gridschedulergridscheduler

Now I am trying to run aimk to get things setup to build.   This is my first
time trying to build GE and it seems a bit daunting and help would be
appreciated.

I am trying to build on rhel5u4.

The build arch is getting set to  lx26-amd64 - is this correct?   My current
install is lx24-amd64.

When I add the following to the aimk.private, it at least starts to build:

set CORE_HOME = /opt/grid-6.2u5/lib/lx24-amd64

But then I get a bunch of errors that look like the following:


../libs/lck/Makefile:103: ../libs/lck/lck_dependencies: No such file or
directory
../libs/rmon/Makefile:73: ../libs/rmon/rmon_dependencies: No such file or
directory
.
.
.
../clients/showq/Makefile:85: ../clients/showq/showq_dependencies: No such
file or directory
../utilbin/Makefile:79: ../utilbin/utilbin_dependencies: No such file or
directory

Any help to point me in the right direction would be greatly appreciated.



--
-MichaelC



More information about the gridengine-users mailing list