[GE users] error resolving local host: can't resolve host name

wzlu wzlu at gate.sinica.edu.tw
Tue Nov 16 00:47:36 GMT 2010


    [ The following text is in the "utf-8" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some characters may be displayed incorrectly. ]

Hi,

Thanks for your reply.
I try some commands and the output as following:

# utilbin/lx24-amd64/gethostbyname in04208.domainname
Hostname: in04208.domainname
Aliases: in04208
Host Address(es): 10.0.4.208
# utilbin/lx24-amd64/gethostbyaddr 10.0.4.208
Hostname: in04208.domainname
Aliases: in04208
Host Address(es): 10.0.4.208
# hostname
in04208.domaniname
# hostname -f
hostname: Unknown host
# hostname --long
hostname: Unknown host
# hostname --short
hostname: Unknown host

I found the command "hostname" output was error.(typing error)
Then I modify the /etc/sysconfig/network, SGE is working fine.

Thanks a lot.

Best Regards,
Lu
? 2010/11/15 ?? 05:15, reuti ??:
> Am 13.11.2010 um 03:59 schrieb wzlu:
>
>> Dear All,
>>
>> I changed a execution host IP and change qmaster of this execution host.
>>
>> After modify DNS, IP, hostname, /etc/hosts and act_qmaster, I used gethostbyname, gethostbyaddr and gethostname to check FQDN.
>>
>> gethostbyname and gethostbyaddr are correct:
>> gethostbyname in04208.domainname
> Is also:
>
> $ gethostbyname in04208
>
> working? What does:
>
> $ hostname
>
> resp. with the options --short or --long show?
>
> -- Reuti
>
>
>> Hostname: in04208.domainname
>> Aliases:  in04208
>> Host Address(es): 10.0.4.208
>>
>> gethostbyaddr 10.0.4.208
>> Hostname: in04208.domainname
>> Aliases:  in04208
>> Host Address(es): 10.0.4.208
>>
>> but gethostname show following message.
>> error resolving local host: can't resolve host name (h_errno = HOST_NOT_FOUND)
>>
>> Try to start sgeexecd:
>> error resolving local host: can't resolve host name (h_errno = HOST_NOT_FOUND)
>> error resolving local host: can't resolve host name (h_errno = HOST_NOT_FOUND)
>>    starting sge_execd
>>
>> Try qconf:
>> error: sge_gethostbyname failed
>>
>> /etc/hosts:
>> ...
>> 10.0.4.207              in04207.domainname in04207
>> 10.0.4.208              in04208.domainname in04208
>> 10.0.4.209              in04209.domainname in04209
>> ...
>>
>> /etc/nsswitch:
>> ...
>> hosts:      files dns
>> ...
>>
>> bootstrap:
>> ...
>> ignore_fqdn             false
>> ...
>>
>> Have any idea? Thanks.
>>
>> Best Regards,
>> Lu
>>
>> ------------------------------------------------------
>> http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=295274
>>
>> To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].
> ------------------------------------------------------
> http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=295800
>
> To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].

------------------------------------------------------
http://gridengine.sunsource.net/ds/viewMessage.do?dsForumId=38&dsMessageId=296024

To unsubscribe from this discussion, e-mail: [users-unsubscribe at gridengine.sunsource.net].



More information about the gridengine-users mailing list