[GE users] Cleaning processes that are in different process group @ job end

Ron Chen ron_chen_123 at yahoo.com
Wed Apr 14 01:17:55 BST 2004


I don't use Ocean, but the problem of SGE sometimes
not killing the whole job is a known one. It's the
side effect of a fix, but the root cause comes from a
bug in the Linux NFS daemon.

Take a look at Andy's email:
http://gridengine.sunsource.net/servlets/ReadMsg?msgId=11809&listName=users

So you need to re-enable the code, and compile SGE
from source.

Since 5.3 beta 1 is a little old, may be you should
take this chance to upgrade to SGE p6 which was
released  last week.

 -Ron

--- Jeff Putsch <putsch at mxim.com> wrote:
> Howdy,
> 
> We've got gridengine jobs that occasionally leave
> processes behind. The 
> basic problem is our jobs start related processes
> that end up in a 
> different process group and are not always cleaned
> up at the end of the 
> job. I need to get these reliably terminated when a
> job is terminated.
> 
> I'm running SGE 5.3 Beta 1. I know it's an old
> version and if the 
> behavior described below is fixed in newer versions
> please let me know. 
> If not, any suggestions for solving my problem will
> be greatly 
> appreciated.
> 
> Specifically, we're having problems with the way
> Cadence's ocean 
> scripting/simulator control environment launches the
> simulators (e.g. 
> spectre).
> 
>


	
		
__________________________________
Do you Yahoo!?
Yahoo! Tax Center - File online by April 15th
http://taxes.yahoo.com/filing.html

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list