[GE users] Modify code

Ron Chen ron_chen_123 at yahoo.com
Wed Apr 28 03:51:51 BST 2004


Thanks for the patch, and please discuss development
related issues on the "dev" list.

BTW, did you try with the latest source (SGE 5.3p6)?
Also, if you can provide a scenario that can reproduce
the problem, that would be great too!

I didn't read the shepherd source in detail, may be I
am missing something obvious.

 -Ron


--- casperez at cesga.es wrote:
> 
> Hello,
>   I have sge 5.3p4. When a job finish with fail=100,
> the fields ru_utime and
> ru_stime have value zero. Is there any reason for
> this?
> 
>   I've modified the code to obtain these values in
> any case. I added in
> shepherd.c about the line 2910
> 
>    if (sig == SIGKILL || sig == SIGUSR2 || sig ==
> SIGUSR1 )
>       sig=SIGTERM;
> 
> before
> 
>       kill(pid, sig);
>       switch2admin_user();
>    }
> 
> Can someone tell me if this change can influence the
> behavior of the program?
> 
> 
> 
> 
> 
> 
> 
>
---------------------------------------------------------------------
> To unsubscribe, e-mail:
> users-unsubscribe at gridengine.sunsource.net
> For additional commands, e-mail:
> users-help at gridengine.sunsource.net
> 



	
		
__________________________________
Do you Yahoo!?
Win a $20,000 Career Makeover at Yahoo! HotJobs  
http://hotjobs.sweepstakes.yahoo.com/careermakeover 

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list