[GE users] Question about submitting to a queue with a hostgroup

Chris Dagdigian dag at sonsorol.org
Fri Aug 20 18:54:21 BST 2004


Has anyone confirmed this behaviour as a bug?

I have a new cluster running SGE 6.0u1 that I just set up for someone -- 
there are 64 nodes divided into two racks. I've added hostgroup 
definitions for "racka" and "rackb" that contain the proper hostnames. 
The hostgroups are properly associated with the all.q cluster queue 
configuration.

What I expected to be able to do was something like this so that I could 
limit jobs to running on a certain rack:

qrsh -q all.q@@racka 'hostname'

I can't seem to use queue domain or hostgroup syntax with qsub or qrsh. 
Shouldn't I be able to?

Regards,
Chris



Reuti wrote:

> Hi,
> 
> 
>>I get messages stating, "cannot run in queue instance "low at hostname
>><mailto:low at hostname> " because it is not contained in its hard queue list
>>(-q)" Do I not have the hostgroups and queues not set up correctly or is
>>this not a feature of hostgroups that can be used to submit jobs?
> 
> 
> I can confirm this behavior. According to the definition in `man sge_types` it 
> is a request of a @Dell queue domain and should work. Because qsub is accepting 
> the job in addition, maybe there is a bug in the scheduler.
> 
> Cheers - Reuti
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> For additional commands, e-mail: users-help at gridengine.sunsource.net

-- 
Chris Dagdigian, <dag at sonsorol.org>
BioTeam  - Independent life science IT & informatics consulting
Office: 617-665-6088, Mobile: 617-877-5498, Fax: 425-699-0193
PGP KeyID: 83D4310E iChat/AIM: bioteamdag  Web: http://bioteam.net

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list