[GE users] Library compatibility on OSX

Beth Meyer beth at wildbrain.com
Wed Aug 25 19:19:47 BST 2004


We're using SGEEE 6.0u1 and some of our workstations are Mac OS 10.3.5. 
When we add SGE to the environment on these systems, we are getting a 
library version mismatch.  settings.csh adds a variable called 
DYLD_LIBRARY_PATH to the environment which is set to 
$SGEROOT/lib/darwin.  With this variable set we are getting version 
mismatch errors for our libraries when trying to run other commands, 
like ssh. The error we are getting is this:

dyld: ssh version mismatch for library: 
/wb/apps/sun/sge/lib/darwin/libcrypto.0.9.7.dylib (compatibility version 
of user: 0.9.7 greater than library's version:0.9.0)
Trace/BPT trap

It's always the libcrypto library that it complains about.
Without that environment variable, everything - including the sge 
binaries - appears to work normally.

Has anyone else encountered this problem? Is there a fix? Can I safely 
move aside the libcrypto.0.9.7.dylib or ignore the DYLD_LIBRARY_PATH 
altogether?

Thanks,

Beth


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list