[GE users] qmon segfault - was Re: [GE users] qconf segfault on RH9

Andre Alefeld Andre.Alefeld at Sun.COM
Thu Jul 1 11:00:51 BST 2004


Hi Kervin,

did you uninstall lesstif ? I had a look at RH 7.2 with
host% rpm -qa |grep openmotif
openmotif-2.2.0-1_ICS
openmotif-devel-2.2.0-1_ICS

host% ls -l /usr/X11R6/lib/libXm.so*
lrwxrwxrwx    1 root     bin            14 Mar 18  2002 /usr/X11R6/lib/libXm.so -> libXm.so.2.2.0
lrwxrwxrwx    1 root     bin            14 Mar 18  2002 /usr/X11R6/lib/libXm.so.2 -> libXm.so.2.2.0
-rwxr-xr-x    1 root     bin       6562491 Jan 28  2002 /usr/X11R6/lib/libXm.so.2.2.0

Can you check the following:

% source $SGE_ROOT/default/common/settings.csh
% ldd $SGE_ROOT/bin/lx24-x86/qmon
% ldd $SGE_ROOT/lib/lx24-x86/libXltree.so
% echo $LD_LIBRARY_PATH
% strings /usr/X11R6/lib/libXm.so | grep -i 'Motif Version'

This gives me: @(#)Motif Version 2.1.30

Maybe libXltree.so is wrong, or fetched from a wrong place.

Andre

On Wed, 30 Jun 2004 kervin at adevsoft.com wrote:

>
> It was late :)  Meant Qmon.
>
> I did download the precompiled binaries yes.
>
> Qmon is linked against libXm.so.2, but OpenMotif package that comes with RH9 '
> openmotif-2.2.2-14, openmotif-devel-2.2.2-14 ' provides libXm.so.1 and
> libXm.so.3 but no libXm.so.2 .  I tried linking libXm.so to libXm.so.2, but
> that did not work.
>
> Any suggestions?
>
> Quoting Andre Alefeld <Andre.Alefeld at Sun.COM>:
>
> > Hi Kervin,
> >
> > I guess you mean qmon. qmon was build against OpenMotif and there might be
> > problems with lesstif. Can you give it a try with Openmotif and tell me if
> > the
> > problem still exists.
> > You've been using any precompiled binaries I suppose ?
> >
> > Andre
> >
> > On Wed, 30 Jun 2004 kervin at adevsoft.com wrote:
> >
> > >
> > >
> > > What Motif library was the Linux QConf 6.0 binaries built against?
> > >
> > > QConf currently segfaults against the Redhat 9.0 supplied LessTiff library
> > and
> > > any of its updates.  The segfaults occurs whenever I click on any of the
> > qconf
> > > buttons and apparently originates in the LessTif library.
> > >
> > > Has anyone got qconf to run on Redhat 9?  What Motif library did you use?
> > >
> > > Kervin
> > >
> > > ---------------------------------------------------------------------
> > > To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> > > For additional commands, e-mail: users-help at gridengine.sunsource.net
> > >
> > >
> >
> > - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
> > Andre Alefeld                Phone: ++49 (0)941 3075-255
> > Software Engineering         Fax:   ++49 (0)941 3075-222
> > Sun Microsystems GmbH
> > Dr.-Leo-Ritter-Str. 7	     mailto: andre.alefeld at sun.com
> > D-93049 Regensburg           http://www.sun.com/grid
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> > For additional commands, e-mail: users-help at gridengine.sunsource.net
> >
> >
>
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> For additional commands, e-mail: users-help at gridengine.sunsource.net
>
>

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Andre Alefeld                Phone: ++49 (0)941 3075-255
Software Engineering         Fax:   ++49 (0)941 3075-222
Sun Microsystems GmbH
Dr.-Leo-Ritter-Str. 7	     mailto: andre.alefeld at sun.com
D-93049 Regensburg           http://www.sun.com/grid

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list