[GE users] notes from SGE(ee) 5.3p6 install on an SGI Altix ia64 linux system today

Chris Dagdigian dag at sonsorol.org
Thu Jul 15 22:47:20 BST 2004


Hello,

This is one of those "send a note so it ends up in the archives where 
future searchers may find it and save themselves some time..." sorts of 
emails.

I had the opportunity to build SGE-5.3p6 from source tarball (not CVS) 
on an 16cpu Altix used for computational chemisty today.

There were 2 minor issues and 1 medium-level issue:

1. Issue with qmon compilation needed to be worked around
2. Isue with rshd compilation needed to be worked around
3. Qmon segfaults and crashes only when queue config interface is used

The system:

[root at altix source]# cat /etc/issue
SGI ProPack 3 for Linux, Build 300rp04050615_10072-0405061540

[root at altix source]# uname -a
Linux altix.na.XXXX.net 2.4.21-sgi300rp04050615_10072 #1 SMP Thu May 6 
15:42:50 PDT 2004 ia64 ia64 ia64 GNU/Linux
[root at altix source]#


Issue #1:

The build error is this:

>  making in IA64LINUX/ for IA64LINUX
>  __________Q_M_O_N____________
>  gcc -L/usr/X11R6/lib64 -L. -shared -o libXltree.so ListTree.o DND.o -lXm -lXpm -lXt -lXext -lXmu -lX11 -lSM -lICE -lXp
>  /usr/bin/ld: cannot find -lXm
>  collect2: ld returned 1 exit status
>  make: *** [libXltree.so] Error 1
>  not done

The root cause is in line 1017 of aimk where XLIBD is set to 
"/usr/X11R6/lib64"

The location of Motif on this system was "/usr/X11R6/lib" as 
/usr/X11R6/lib64 did not exist

I tried to add a 'set XLIBD' directive to aimk.site but it did not work 
  so I ended up just manually editing the offending line in the aimk 
build script.



Issue #2:

This is similar to the rshd issue I run into when building on my Mac OS 
X powerbook so this was a quick fix. The error was:


> ____3_r_d_p_a_r_t_y__R_E_M_O_T_E_____ 
>  gcc -O2 -Wall -Werror   -DLINUX -DIA64LINUX  -DENABLE_438_FIX -DCOMPILE_DC -D__SGE_NO_USERMAPPING__ -UKERBEROS   
>  -I../../../daemons/common -I../../../common -I../../../libs/uti -I../../../daemons/shepherd -c ../rshd.c
>  cc1: warnings being treated as errors
>  ../rshd.c:110: warning: redefinition of `in_port_t'
>  /usr/include/netinet/in.h:92: warning: `in_port_t' previously declared here
>  make: *** [rshd.o] Error 1

The quick fix here was just commenting out the in_port_t declaration in 
line 110 of ./3rdparty/remote/rshd.c


Issue #3

For some reason that I did not have time to debug 'qmon' will segfault 
if I bring up the queue control interface. Everything else seemed fine 
and I used the interface to set up some functional share policy settings 
without any trouble at all.

We left this as-is since the Altix is just going to run a single 16-slot 
queue and I don't think qmon is going to be used all that often.


Regards,
Chris

-- 
Chris Dagdigian, <dag at sonsorol.org>
BioTeam  - Independent life science IT & informatics consulting
Office: 617-665-6088, Mobile: 617-877-5498, Fax: 425-699-0193
PGP KeyID: 83D4310E iChat/AIM: bioteamdag  Web: http://bioteam.net

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list