[GE users] wallclock time limit in qmon

Andy Schwierskott andy.schwierskott at sun.com
Tue Jul 20 15:43:57 BST 2004


Alexandre,

this must be qmon bug. I treid the same and the job has a 0 second request:

> qstat -r
job-ID  prior   name       user         state submit/start at     queue    slots ja-task-ID 
-----------------------------------------------------------------------------------------------------------------
     227 0.56000 sleeper.sh andy         qw    07/20/2004 16:42:03          1
        Full jobname:     sleeper.sh
        Hard Resources:   h_rt=0 (0.000000)
        Soft Resources:


could you please file a bug in Issuezilla?

Thanks,
Andy

> hello,
>
> when I set a wallclock time limit using qmon, SGE 6.0 adds the option "-hard 
> -l h_rt=00:02:00" to my script: (I see that in using the option "save 
> settings")
> then, the job starts and ends after 10 seconds although my test script should 
> run quite a long time
>
> when I try to launch "qsub -hard -l h_rt=00:02:00 myscript" from the command 
> line, it ends after 10 seconds too: same issue
>
> but when I try "qsub -l h_rt=00:02:00 myscript", it stops after 2 minutes as 
> expected!
>
> I think the right command is "-l h_rt" and not "-hard -l h_rt" so it appears 
> there is a bug with the wallclock time limit when using qmon.
> Does anyone encounter the same issue, or I do something wrong ?
>
> Alexandre

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list