[GE users] Two networks cards in qmaster with SGE 6.0 problem

Reuti reuti at staff.uni-marburg.de
Thu Jun 24 18:22:24 BST 2004


    [ The following text is in the "ISO-8859-1" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]

Hi everyone,

according to the HowTo for having two network interfaces (at least in the 
qmaster machine) I set up a cluster with 5.3p6 and earlier and it is working as 
intended. Because only the qmaster has two network interfaces, there is only 
one line in the host_aliases file. The act_qmaster file contains the internal 
name of the machine to the cluster. hostname gives the external name.

Now I tried this with 6.0. Although "gethostbyname -aname" responses in both 
cases with the correct internal name (to the cluster) of the machine, starting 
the qmaster stops before starting the scheduler, stating that it can't start 
the scheduler, because the qmaster is not running on this machine - but it is 
already running. The problem seems to be, that after starting the qmaster on 
the internal interface, it is writing to the act_qmaster file again the name of 
the external interface and changing my entry there. This would explain why the 
test for the running qmaster fails.

I checked also with the 5.3p6 installation, and according to the modify date of 
the act_qmaster file, it's also written there when starting the qmaster. I 
wasn't aware of this. But because it's written there with the correct entry 
it's working.

I simply tried to change the protection of the act_qmaster file to prohibit the 
change, but then the qmaster will really not start, and leaving only a message 
in the message file complaining about the wrong file protection.

Has anyone such a configuration working with 6.0? - Reuti

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list