[GE users] DB4 version on Redhat?

Bogdan Lobodzinski bogdan at ifh.de
Wed Jun 30 12:48:04 BST 2004


Hello,

I did a compilation of SGE 6.0 from source on SuSE 8.2 and I found
that DB_RPCCLIENT flag must be changed in the file:
libs/spool/berkeleydb/sge_bdb.c

You need to replace:
--------
...
if (server != NULL) {
         flags |= DB_RPCCLIENT;
      }
...
--------
by:
--------
...
if (server != NULL) {
         flags |= DB_CLIENT;
      }
...
--------

I also have sent to [GE users] similar question about Berkely DB version.
Up to now I did not find any response.


                           Best Regards,

                              Bogdan

On Wed, 30 Jun 2004, John Hearns wrote:

> I'm compiling V6.0 from source, so I can include the
> recent privileged_port patch.
>
> On Redhat, the installed Berkely DB library is 4.1
> Has anyone hadd success in compiling using:
> BERKELEYDB_SHARED_LIBRARIES="libdb-4.1"
> BERKELEYDBBASE=/usr/lib
> I'm just trying this now myself. Would v 4.1 be sufficient?
>
>
> Also are the aimk switches for classic and Berkely spooling mutually
> exclusive? I thought you could choose this at install time.
>
> -spool-berkeleydb -> use berkeleydb spooling
> -spool-classic    -> use classic flatfile spooling
>
> I guess -spool-berkelydb includes the classic type also?
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> For additional commands, e-mail: users-help at gridengine.sunsource.net
>



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list