[GE users] Large memory footprint for sge_qmaster

Andy Schwierskott andy.schwierskott at sun.com
Wed Jun 30 14:30:23 BST 2004


Sean,

did you read the 6.0 announcement and issue 1087 which requires to set
"schedd_job_info" setting to "false":

   http://gridengine.sunsource.net/issues/show_bug.cgi?id=1087

Andy

> Yesterday afternoon I upgrade my cluster from SGE5.3 to SGE6.0.  Within
> an hour of bringing things up, I saw the footprint of sge_qmaster get up
> to over 50MB (I had seen it under 40MB a little earlier).  I thought
> this was a bit high, however after watching it for a little while I saw
> the size jump up and down some (by several MB), so I assumed it was just
> normal.   Now I look at it this morning and sge_qmaster is taking up
> 522MB (was 528MB when I woke up a couple hours ago).  Also, sge_schedd
> is sitting at 177MB.  This is looking more and more like a memory leak
> to me.  Has anyone else seen this?  Does anyone have any idea what might
> be causing it or how to fix it?
>
> The cluster in question has 116 compute nodes, each dual processor.
> About 240 jobs have been submitted to SGE since I upgraded, some MPI,
> some uni-processor.  Most of them were submitted within an hour of
> turning SGE back on.  A couple were submitted in the early hours this
> morning.
>
> SGE was compiled from source with berkeley db spooling turned off (not
> even compiled in).
>
> Thanks,
>
>
> Sean

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list