[GE users] ODD Behavior with an interactive session

Charles_Hook at freddiemac.com Charles_Hook at freddiemac.com
Tue Nov 9 19:40:09 GMT 2004


Thanks for the suggestion.  It turns out that the oddity was due to the
grid queues being set to use a c-shell for jobs, and the SAS application is
normally run as a k-shell.  So the behavior we were seeing was reasonable
for C-shell but unexpected.




Thanks,
Charles Hook
SAS Administration


(Embedded image moved to file: pic26456.gif)



                                                                           
             "Terry Lalonde"                                               
             <tlalonde at potenti                                             
             asemi.com>                                                 To 
                                       users at gridengine.sunsource.net      
             11/09/2004 09:44                                           cc 
             AM                                                            
                                                                   Subject 
                                       RE: [GE users] ODD Behavior with an 
             Please respond to         interactive session                 
             users at gridengine.                                             
               sunsource.net                                               
                                                                           
                                                                           
                                                                           
                                                                           




Charles:

   I would look for environment variables, that are required for
functionality of SAS application, that may not be set properly for the
Grid jobs.

Perhaps you can compare an environment dump from a working session
to a grid job's env as a start.

   We have seen that some environment variables are inherited from the
exec-daemon's process.

Terry

> -----Original Message-----
> From: Charles_Hook at freddiemac.com [mailto:Charles_Hook at freddiemac.com]
> Sent: Monday, November 08, 2004 7:41 PM
> To: users at gridengine.sunsource.net
> Subject: [GE users] ODD Behavior with an interactive session
>
> We have just upgraded SGEEE to version 6 from 5.3, and I have a
question
> about a change in behavior.
>
> We are using the SGE software to load balance mostly between two hosts
> which run SAS software.  We are using a wrapper script to call the SAS
> interactive XWindows sessions that looks like this
>
> qrsh -N "IntrActv" -cwd -V -verbose  ". ~/.profile;.
> /udb/home/db2ac/sqllib/db2profile;/opt/sas/sasi.pl" $*
>
> with version 5.3 all functions in the open Xwindows session worked
fine
> including SAS's ability to shell out to the OS and run OS commands.
After
> the upgrade, the shell commands from within the SAS programs are not
> working.  Quite literally, the only change was Grid Engine.  I am
having
> difficulty drawing the line between the cause and the apparent
effects.
>
> (the call to the .profile was a solution to a printing issue found
with
> the
> 5.3 version.  Interactive SAS won't send jobs to the printer properly
> unless the .profile had been sourced one the job landed on the
execution
> host)
>
>
> Thanks,
> Charles Hook
> SAS Administration
> Freddiemac
>
>
> (Embedded image moved to file: pic30596.gif)


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




    [ Part 2, Image/GIF (Name: "pic26456.gif") 1.4 KB. ]
    [ Unable to print this part. ]


    [ Part 3: "Attached Text" ]

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net



More information about the gridengine-users mailing list