[GE users] 6.0 qstat - possible RFE

John Coldrick jc at axyzfx.com
Wed Nov 10 20:56:09 GMT 2004


    [ The following text is in the "utf-8" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some characters may be displayed incorrectly. ]

On Wednesday 10 November 2004 15:40, Kirk Patton wrote:

> The SGE_ROOT is hardcoded at the top of the script.  You will need to
> change it for your site if you decide to use it.

	Actually, FYI it's defined but not referenced...I had to skim farther down 
and hack in the path.  I couldn't get it to do anything, but it was a cursory 
glance.  I suspect, based on the path to qstat containing "linux", that this 
was originally SGE 5.3?  For me, the SGE6 binary path contains lx26-x86 and 
similar.  That may explain why it didn't do anything - qstat params may have 
changed.

	It's odd, I was just this afternoon starting to look at writing a Python XML 
parser for 'qstat -xml' output.  Seems like useful data and the way to go if 
you're starting from scratch...

	Cheers,

	J.C.


-- 
John Coldrick                  www.axyzfx.com        Axyz Animation
Houdini/Renderman/Discreet                           425 Adelaide St W
416-504-0425                                         Toronto, ON Canada
jc at axyzfx.com                                        M5V 1S4
-----------------------------------------------------------------------
I used to work in a fire hydrant factory.  You couldn't park anywhere
near the place.
		-- Steven Wright

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list