[GE users] One last concern

Paul Mitchell pmitchel at email.unc.edu
Thu Nov 18 20:01:23 GMT 2004


Hello,
  It finally dawned on me that the "can't read usage file" problem I was
bedeviled with had everything to do with AFS home directories. duh.  Using
the local account I set up to admin SGE, it worked fine.  Obviously, the
rcp portion of the file_sharing mechanism was unable to update the AFS
space without a token.

While skimming the net, I discovered the "-afs" flag to the
install_qmaster and install_execd programs.  This resulted in me scouring
old gridengine mail lists letters concering the set_token, get_token
commands and the like.  It's amazing that this material is not a part of
the gridengine source tree (gripe, gripe).

I did, however, manage to download a set of programs, get_token, set_token
and prolong_token which I've hacked into working order (though I'm gettig
a library conflict when I run them as a valid AFS user):

./get_token
dyld: ./get_token version mismatch for library:
/usr/local/sge/lib/darwin/libssl.0.9.7.dylib (compatibility version of
user: 0.9.7 greater than library's version: 0.9.0)
Trace trap

(This probably has to do with the Kerberos compilation on out Kerberos
servers, and I may have down -rev my local libssl librarires to clear it
up).

If anyone out there has a sucessfull implimentation of gridengine with AFS
(on OS X) and feels like sharing some info on how these two programs
should be called (in other words, I'm missing the  get_token_cmd and
set_token_cmd files) I"d be grateful.

Thanks for your time,

Paul Mitchell
==============================================================================
	Paul Mitchell
	email: pmitchel at email.unc.edu
	phone: (919) 962-9778
	office: I have an office, room 14, Phillips Hall
==============================================================================




---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list