[GE users] LD_LIBRARY_PATH (was: One last concern)

John Coldrick jc at axyzfx.com
Fri Nov 19 14:07:51 GMT 2004


    [ The following text is in the "iso-8859-1" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]

On Thursday 18 November 2004 23:39, Ron Chen wrote:

> If you look at the code, you will see that we don't
> pass the absolute path to dlopen() -- but rely on the
> LD_LIBRARY_PATH (or DYLD_LIBRARY_PATH for OSX)
> settings. It is not hard to add a bit of code to
> change this behaviour, so that SGE will read from the
> config file to find out where the libraries are.

	Silly question, but I've been having some hassle with the Berkely db+SGE6 and 
LD_LIBRARY_PATH - is there a particularly good reason, 
programming/security-wise, that SGE can't just reference directly all the 
libs that are distributed with it, at least as a first option, rather than 
relying on stomping over this envar?  Essentially I need to stick the SGE 
version at the end of the list - downloading and compiling the latest db 
isn't the most elegant solution given I already have "standard" old and new 
versions maintained by rpm.  I'm just not clear why this couldn't be a 
generic RFE for all the libs, rather than justdlopen().

	Cheers,

	J.C.


-- 
John Coldrick                  www.axyzfx.com        Axyz Animation
Houdini/Renderman/Discreet                           425 Adelaide St W
416-504-0425                                         Toronto, ON Canada
jc at axyzfx.com                                        M5V 1S4
-----------------------------------------------------------------------
Never eat more than you can lift.
		-- Miss Piggy

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list