[GE users] Re: SGE 6.0 for NetBSD

Dan McMahill dmcmahill at NetBSD.org
Wed Oct 20 00:36:13 BST 2004


On Tue, Oct 19, 2004 at 11:16:06AM -0600, Co Thai Ngo wrote:
> Hi all, 
>  
> I'm trying to install SGE 6.0 on NetBSD 1.6.1. I've installed the Berkeley DB 
> and changed the Makefile, source and script files as what they did with SGE 
> 5.3. The make command runs smoothly. But I got the below errors when I run make 
> install 

> ************** 
> acacia# make install 
> ===> Checking for vulnerabilities in sge-V60_TAG-srcnb1 
> ===> Installing for sge-V60_TAG-srcnb1 
> Group 'sgeadmin' already exists. 
> User 'sgeadmin' already exists. 
> /bin/mkdir -p /usr/pkg/sge 
> /usr/sbin/chown sgeadmin /usr/pkg/sge 
> /usr/bin/chgrp sgeadmin /usr/pkg/sge 
> cd /usr/pkgsrc/wip/sge-test/work/gridengine/source &&  echo "Y" | /usr/bin/env 
> LOCALBASE=/usr/pkg SGE_ROOT=/usr/pkg/sge ./scripts/distinst -local -allall 
> nbsd-i386 
> OPENSSLBASE: not found 

looks like the distinst script needs some work.  Did you take a look at
how the 5.3 package patches that file?  It looks like that probably
isn't enough and you'll need to do some more work.

>     Installing: sge_qmaster sge_execd sge_shadowd sge_schedd sge_shepherd 
> sge_coshepherd qstat qsub qalter qconf qdel qacct qmod qsh utilbin jobs qmon 
> qhost qmake qtcsh qping distcommon 
>  Architectures: nbsd-i386 
> Base directory: /usr/pkg/sge 
>    OK [Y/N][Y]: 
> Installing "3rd_party/" directory tree 
> Installing "inst_sge", "install_qmaster" and "install_execd" 
> Installing "util/" directory tree 
> Installing "examples/jobs" 
> Copying Pixmaps and Qmon resource file 
> cp: dist/qmon/Qmon: No such file or directory 
>  
> This command failed: cp dist/qmon/Qmon /usr/pkg/sge/qmon 
>  
> Installation failed. Exiting. 
>  
> *** Error code 1 
>  
> Stop. 
> make: stopped in /usr/pkgsrc/wip/sge-test 
> *** Error code 1 
>  
>  
> *********** 
>  
> It seems that the binary files (qmon, sge_qmaster, sge_schedd...) are not 
> created. I don't know what step is missing or what I should add to SGE 6.0 
> source files to make it run on NetBSD. Any advice or comment ? Has any of you 
> tried SGE 6.0 on NetBSD. What problem are you facing with ? If it's success, 
> could you please send me the package or post it on CVS. 
  
I have not tried out SGE 6.0.  As a first step, I'd recommend going through
all of the patches and seeing which ones may still be needed and which ones
have been fixed in the SGE source tree.  My guess is it will be obvious
for some and not so obvious for others.  You may have to redo some of those
patches.

Then log the entire build and dig into all the errors.  SGE doesn't have
the nicest build system in the world which makes it somewhat painful to
deal with.  Good luck!

-Dan

-- 

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list