[GE users] SGE 6.0 for NetBSD

Andre Alefeld Andre.Alefeld at Sun.COM
Wed Oct 20 13:20:32 BST 2004


Hi,

OPENSSLBASE is defined in scripts/distinst.site, this must be adjusted to wherever your openssl is
installed (take care it has to be openssl-0.9.7d).

The cp error might be a consequence of an incomplete build of qmon, since dist/qmon/Qmon is
generated during the build.

What was the output during the aimk run ?

Andre

Co Thai Ngo wrote:
> Hi all, 
>  
> I'm trying to install SGE 6.0 on NetBSD 1.6.1. I've installed the Berkeley DB 
> and changed the Makefile, source and script files as what they did with SGE 
> 5.3. The make command runs smoothly. But I got the below errors when I run make 
> install 
>  
> ************** 
> acacia# make install 
> ===> Checking for vulnerabilities in sge-V60_TAG-srcnb1 
> ===> Installing for sge-V60_TAG-srcnb1 
> Group 'sgeadmin' already exists. 
> User 'sgeadmin' already exists. 
> /bin/mkdir -p /usr/pkg/sge 
> /usr/sbin/chown sgeadmin /usr/pkg/sge 
> /usr/bin/chgrp sgeadmin /usr/pkg/sge 
> cd /usr/pkgsrc/wip/sge-test/work/gridengine/source &&  echo "Y" | /usr/bin/env 
> LOCALBASE=/usr/pkg SGE_ROOT=/usr/pkg/sge ./scripts/distinst -local -allall 
> nbsd-i386 
> OPENSSLBASE: not found 
>  
>     Installing: sge_qmaster sge_execd sge_shadowd sge_schedd sge_shepherd 
> sge_coshepherd qstat qsub qalter qconf qdel qacct qmod qsh utilbin jobs qmon 
> qhost qmake qtcsh qping distcommon 
>  Architectures: nbsd-i386 
> Base directory: /usr/pkg/sge 
>    OK [Y/N][Y]: 
> Installing "3rd_party/" directory tree 
> Installing "inst_sge", "install_qmaster" and "install_execd" 
> Installing "util/" directory tree 
> Installing "examples/jobs" 
> Copying Pixmaps and Qmon resource file 
> cp: dist/qmon/Qmon: No such file or directory 
>  
> This command failed: cp dist/qmon/Qmon /usr/pkg/sge/qmon 
>  
> Installation failed. Exiting. 
>  
> *** Error code 1 
>  
> Stop. 
> make: stopped in /usr/pkgsrc/wip/sge-test 
> *** Error code 1 
>  
>  
> *********** 
>  
> It seems that the binary files (qmon, sge_qmaster, sge_schedd...) are not 
> created. I don't know what step is missing or what I should add to SGE 6.0 
> source files to make it run on NetBSD. Any advice or comment ? Has any of you 
> tried SGE 6.0 on NetBSD. What problem are you facing with ? If it's success, 
> could you please send me the package or post it on CVS. 
>  
> Thank you very much, 
>  
> --  
> Co Thai Ngo  
> Dept. of Biology   
> New Mexico State University   
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> For additional commands, e-mail: users-help at gridengine.sunsource.net
> 

-- 
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Andre Alefeld                Phone: ++49 (0)941 3075-255
Software Engineering         Fax:   ++49 (0)941 3075-222
Sun Microsystems GmbH
Dr.-Leo-Ritter-Str. 7	     mailto: andre.alefeld at sun.com
D-93049 Regensburg           http://www.sun.com/grid


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list