[GE users] SGE6 and libdb-4.2.so

John Coldrick jc at axyzfx.com
Tue Oct 26 20:47:46 BST 2004


	I've run into a collision with the settings.sh for SGE and Subversion on SUSE 
9.1... SGE setup tweaks LD_LIBRARY_PATH to include

 	SGE_ROOT/lib/<kernel> 
prior to the regular system settings.   What this does is cause Berkely DB to 
muss up - I get the dreaded 

db_stat: error while loading shared libraries: db_stat: undefined symbol: 
db_version

	whenever I try to run a db command.  Basically it's a collision of different 
db versions.  Removing the SGE entry from LD_LIBRARY_PATH removes the 
problem.  So my question is:

	for execd or submission systems, do i need the path to the SGE-distributed 
libdb-4.2.so?  If I do, is it OK to just remove that anyway since I have that 
library installed in SUSE 9.1?

	Thanks

	J.C.

-- 
John Coldrick                  www.axyzfx.com        Axyz Animation
Houdini/Renderman/Discreet                           425 Adelaide St W
416-504-0425                                         Toronto, ON Canada
jc at axyzfx.com                                        M5V 1S4
-----------------------------------------------------------------------
The very ink with which all history is written is merely fluid
prejudice.
		-- Mark Twain

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list