[GE users] SGE6 and libdb-4.2.so

Reuti reuti at staff.uni-marburg.de
Tue Oct 26 21:08:34 BST 2004


    [ The following text is in the "ISO-8859-1" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]

Hi,

> 	I've run into a collision with the settings.sh for SGE and Subversion on
> SUSE 
> 9.1... SGE setup tweaks LD_LIBRARY_PATH to include
> 
>  	SGE_ROOT/lib/<kernel> 
> prior to the regular system settings.   What this does is cause Berkely DB to
> 
> muss up - I get the dreaded 
> 
> db_stat: error while loading shared libraries: db_stat: undefined symbol: 
> db_version
> 
> 	whenever I try to run a db command.  Basically it's a collision of different
> 
> db versions.  Removing the SGE entry from LD_LIBRARY_PATH removes the 
> problem.  So my question is:
> 
> 	for execd or submission systems, do i need the path to the SGE-distributed
> 
> libdb-4.2.so?  If I do, is it OK to just remove that anyway since I have that
> 
> library installed in SUSE 9.1?

seems that the exact version is not included in the name - it's v4.2.52. So, to 
be on the safe side I would suggest to download the latest version from 
sleepycat.com and use this for both programs.

Cheers - Reuti

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list