[GE users] SGE6 and libdb-4.2.so

Andreas Haas Andreas.Haas at Sun.COM
Wed Oct 27 10:33:23 BST 2004


On Tue, 26 Oct 2004, John Coldrick wrote:

>
> 	I've run into a collision with the settings.sh for SGE and Subversion on SUSE
> 9.1... SGE setup tweaks LD_LIBRARY_PATH to include
>
>  	SGE_ROOT/lib/<kernel>
> prior to the regular system settings.   What this does is cause Berkely DB to
> muss up - I get the dreaded
>
> db_stat: error while loading shared libraries: db_stat: undefined symbol:
> db_version
>
> 	whenever I try to run a db command.  Basically it's a collision of different
> db versions.  Removing the SGE entry from LD_LIBRARY_PATH removes the
> problem.  So my question is:
>
> 	for execd or submission systems, do i need the path to the SGE-distributed
> libdb-4.2.so?  If I do, is it OK to just remove that anyway since I have that
> library installed in SUSE 9.1?

Well, qmon links a $SGE_ROOT/lib library shared based on LD_LIBRARY_PATH.
But only qmaster and some utilities in utilbin depend upon libdb-4.2.so.
So removing SGE entry from LD_LIBRARY_PATH always must be fine as
long as you do not operate a CSP system (install_qmaster -csp). This is
because the libraries with CSP are needed also by clients and execds.

Andreas

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list