[GE users] trouble selecting specific instance queue

Andy Schwierskott andy.schwierskott at sun.com
Tue Sep 28 09:43:34 BST 2004


Terry,


> interestingly there is a list of queues:  "servers.q,desktops.q,servers.q at janet"
>
> we do have the line -q servers.q,desktops.q in our
> sge_request file.  But should the command line -q
> argument not override the sge_request values? It appears
> to be supplimenting it.

That's a good question - I'm not sure what to think about it.

E.g. Other submit options (not resource requests) supplement the sge_request
as well (e.g. the "-m" mail option).

The "-q" switch is somewhat special - it's SGE's only true OR resource
request for resources.

I'm really not sure what to think about, but I think to be coherent with the
"-l" resource requests the "-q" should be replaced and should not
supplement.

Any opinions about it?

Andy

> BTW:  I see the same behaviour using qsub.
>
> servers.q:janet:users:tlalonde:echo $QUEUE ; hostname:1140:sge:0:1096298461:1096298425:1096298426:0:0:1:0:0:0.000000:0:0:0:0:12235:16074:0:0.000000:0:0:0:0:0:0:NONE:defaultdepartment:NONE:1:0:0.000000:0.000000:0.000000:-q servers.q,desktops.q,servers.q -I y:0.000000:NONE:0.000000
>
> servers.q:janet:users:tlalonde:echo $QUEUE ; hostname:1141:sge:0:1096298474:1096298438:1096298438:0:0:0:0:0:0.000000:0:0:0:0:12215:16024:0:0.000000:0:0:0:0:0:0:NONE:defaultdepartment:NONE:1:0:0.000000:0.000000:0.000000:-q servers.q,desktops.q,servers.q at janet -I y:0.000000:NONE:0.000000
>
> servers.q:janet:users:tlalonde:echo $QUEUE ; hostname:1142:sge:0:1096298483:1096298447:1096298448:0:0:1:0:0:0.000000:0:0:0:0:12147:15798:0:0.000000:0:0:0:0:0:0:NONE:defaultdepartment:NONE:1:0:0.000000:0.000000:0.000000:-q servers.q,desktops.q,servers.q at ren -I y:0.000000:NONE:0.000000
>
> -----Original Message-----
> From: Andy Schwierskott [mailto:andy.schwierskott at sun.com]
> Sent: Monday, September 27, 2004 12:31 PM
> To: users at gridengine.sunsource.net
> Subject: Re: [GE users] trouble selecting specific instance queue
>
>
> Hi,
>
> that's interesting feedback - issue #1234 says that submit to a queue domain
> (=hostgroup) does not work.
>
> Looks like you discoverd a new bug - could you please verify the result with
> the corresponding line in your "accounting" file?
>
> Does it happen for non-qrsh jobs as well?
>
> Andy
>
>>  Using SGE 6.0u1:
>>
>>  I cannot seem to select a specific instance queue, when
>> Also when I echo $QUEUE I get the cluster queue.  I should
>> be able to select a specific instance queue right?
>>
>> session log:
>>
>>> qrsh -q servers.q 'echo $QUEUE ; hostname'
>> servers.q
>> janet
>>
>>> qrsh -q servers.q at janet 'echo $QUEUE ; hostname'
>> servers.q
>> janet
>>
>>> qrsh -q servers.q at ren 'echo $QUEUE ; hostname'
>> servers.q
>> janet
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> For additional commands, e-mail: users-help at gridengine.sunsource.net
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> For additional commands, e-mail: users-help at gridengine.sunsource.net
>
>


Regards,
Mit freundlichen Gruessen,
Andy
Schwierskott

--
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Andy Schwierskott           Tel: +49 (0)941 3075-200 (x60200)
N1 Grid Engine Engineering  Fax: +49 (0)941 3075-222 (x60222)
Sun Microsystems GmbH
Dr.-Leo-Ritter-Str. 7       mailto:andy.schwierskott at sun.com
D-93049 Regensburg          http://www.sun.com/gridware

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list