[GE users] Slots limitation ....

Reuti reuti at staff.uni-marburg.de
Fri Apr 1 11:36:23 BST 2005


    [ The following text is in the "ISO-8859-1" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]

Hi Chanh,

I asked about the evaluation installation as I see no speed benefit running a 
parallel job on a single CPU machine. Having 8 slots for serial jobs to allow 
some kind of time sharing between users is okay, although each job will run 
longer of course.

Back to your problem: 7 is just the "load_thresholds      np_load_avg=1.75" 
times 4 it seems.

Can you try setting it to NONE? As you don't honor the np_load_avg now, you can 
also optimize the scheduler by setting with "qconf -msconf":

job_load_adjustments       NONE
load_adjustment_decay_time 0:0:00

Cheers - Reuti


Quoting TRAN Chanh <chanh.tran at dassault-aviation.fr>:

> Hi Reuti,
> 
> Here 're the infos :
> 
> Case w/ 2_proc machine 'nvb0' :
> 
> #####################################################
> 
> processor  : 0
> vendor     : GenuineIntel
> arch       : IA-64
> family     : Itanium 2
> model      : 1
> revision   : 5
> archrev    : 0
> features   : branchlong
> cpu number : 0
> cpu regs   : 4
> cpu MHz    : 1495.930995
> itc MHz    : 1495.930995
> BogoMIPS   : 2239.75
> 
> processor  : 1
> vendor     : GenuineIntel
> arch       : IA-64
> family     : Itanium 2
> model      : 1
> revision   : 5
> archrev    : 0
> features   : branchlong
> cpu number : 0
> cpu regs   : 4
> cpu MHz    : 1495.930995
> itc MHz    : 1495.930995
> BogoMIPS   : 2239.75
> 
> 
> ####################################################
> 
> qconf -sq test.q
>  ==> SGE version 5.3p6
> qname                test.q
> hostname             nvb0.dassault-avion.fr
> seq_no               0
> load_thresholds      np_load_avg=1.75
> suspend_thresholds   NONE
> nsuspend             1
> suspend_interval     00:05:00
> priority             0
> min_cpu_interval     00:05:00
> processors           UNDEFINED
> qtype                BATCH INTERACTIVE PARALLEL
> rerun                FALSE
> slots                10
> tmpdir               /tmp
> shell                /bin/csh
> shell_start_mode     NONE
> prolog               NONE
> epilog               NONE
> starter_method       NONE
> suspend_method       NONE
> resume_method        NONE
> terminate_method     NONE
> notify               00:00:60
> owner_list           NONE
> user_lists           NONE
> xuser_lists          NONE
> subordinate_list     NONE
> complex_list         NONE
> complex_values       NONE
> calendar             NONE
> initial_state        default
> s_rt                 INFINITY
> h_rt                 INFINITY
> s_cpu                INFINITY
> h_cpu                INFINITY
> s_fsize              INFINITY
> h_fsize              INFINITY
> s_data               INFINITY
> h_data               INFINITY
> s_stack              INFINITY
> h_stack              INFINITY
> s_core               INFINITY
> h_core               INFINITY
> s_rss                INFINITY
> h_rss                INFINITY
> s_vmem               INFINITY
> h_vmem               INFINITY
> 
> #########################################################
> 
> qconf -sp test
>  ==> SGE version 5.3p6
> pe_name           test
> queue_list        test.q
> slots             10
> user_lists        NONE
> xuser_lists       NONE
> start_proc_args   /bin/true
> stop_proc_args    /bin/true
> allocation_rule   $pe_slots
> control_slaves    FALSE
> job_is_first_task FALSE
> 
> #########################################################
> 
> #!/bin/ksh
> 
> 
> #$ -S /bin/ksh
> #$ -o /tmp/test.out
> #$ -j y
> 
> #$ -pe test 8
> 
> sleep 60
> 
> #########################################
> 
> works only w/ nb_slots < 8 !!!
> 
> #######################################
> 
> I don't know what you mean by "evaluation installation for parallel 
> programs",
> matter-of-factly my SGE has been set up for quite a while already & has 
> got no pb running // jobs.
> The new thing is up to now I always have 'nb_slots = nb_procs' .....
> 
> CU,
> Chanh
> 
> Reuti wrote:
> 
> >Hi,
> >
> >do you request any resources by default or explicitly for your jobs (memory,
> 
> >licenses,...)? Please post your queue/PE definition and how you submit (is
> it 
> >an evaluation installation for parallel programs?).
> >
> >CU - Reuti
> >
> >Quoting TRAN Chanh <chanh.tran at dassault-aviation.fr>:
> >
> >  
> >
> >>Hi all,
> >>
> >>I'm using 5.3p6 & my pb is :
> >>
> >>- I 've  :
> >>    a machine w/ one single processor,
> >>    a queue named 'single.q' w/ 8 slots,
> >>    a PE named 'pe_8'
> >>
> >>With all the 8 slots available, I can submit jobs requesting up to 4 
> >>slots but not > 4
> >>w/ msg "cannot run because resources requested are not available for 
> >>parallel job"
> >>
> >>The same thing w/ a 2_processor machine & the limit this time is 7 
> >>instead of 4.
> >>
> >>Is there a limitation on the number of slots  in regard to the  number 
> >>of  processors ???
> >>
> >>Thanks in advance for any explanations,
> >>Chanh
> >>
> >>
> >>---------------------------------------------------------------------
> >>To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> >>For additional commands, e-mail: users-help at gridengine.sunsource.net
> >>
> >>    
> >>
> >
> >
> >
> >---------------------------------------------------------------------
> >To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> >For additional commands, e-mail: users-help at gridengine.sunsource.net
> >
> >
> >  
> >
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> For additional commands, e-mail: users-help at gridengine.sunsource.net
> 



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list