[GE users] sge_security errors

Paul Mitchell pmitchel at email.unc.edu
Wed Apr 6 19:44:03 BST 2005


On Wed, 6 Apr 2005, Rayson Ho wrote:

> Try removing the word "PROTOTYPE".
>
> This is also needed for the Kerberos. (read the "[GE users] SGE+Kerberos
> support" thread for detail)

Right. This has, unfortunately, reawoken my memories of the last time I
tried compiling these things.

 ./aimk -gss
making in darwin/ for darwin
gcc -DKERBEROS -I/usr/local/include/gssapi -I/usr/local/include  -c
../sge_gsslib.c
gcc -o get_cred -L/usr/local/lib  get_cred.o sge_gsslib.o -lgssapi_krb5
-lkrb5 -lk5crypto -lcom_err
ld: Undefined symbols:
_kg_get_context
make: *** [get_cred] Error 1

As I recall, I had to get our "Ace" programmer to manually link this
altogether.  Thanks Rayson.

Paul Mitchell


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list