[GE users] Help configuring grid to use ssh instead of rsh

Reuti reuti at staff.uni-marburg.de
Thu Apr 7 23:34:14 BST 2005


    [ The following text is in the "ISO-8859-1" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]

Hi,

Quoting Gary Thomas <gthomas at ForteDS.com>:

> Hi, We have a grid setup with 30+ machines, and we've been having a lot
> of problems
> 
> Lately with "poll" failures and "unable to read return code" failures.
> I'm trying to switch

with such an amount of nodes there shouldn't be any problem like this. Are your 
jobs generating heavy network traffic? One or two network cards in each 
machine?

> 
> Over to using ssh to see if it has fewer problems, but I cant seem to
> get it to work consistently.
> 

You setup a passwordless login for ssh and configured SGE according to the 
Howto at sunsource.net? Which platform and SGE version? Classic-spooling (to 
NFS/local) or BDB?

Cheers - Reuti

>  
> 
> I keep getting intermittent errors like this:
> 
>  
> 
> testing rdgrid08.q
> 
> ssh: connect to address 172.16.2.48 port 38916: Connection refused
> 
>  
> 
> If I ^C at this point I get:
> 
>  
> 
> error: error waiting on socket for client to connect: Interrupted system
> call
> 
> error: error reading returncode of remote command
> 
>  
> 
> Is anyone else using ssh, or are the some settings we can tweek for rsh
> to avoid the "poll" and
> 
> "unable to read return code" errors?
> 
>  
> 
> Thanks,
> 
>  
> 
> GT
> 
> 



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list