[GE users] Scripts differing between user enviroment and GridEngine environment

Timothy Bateman timb at cisra.canon.com.au
Sun Apr 10 01:06:16 BST 2005


I've been researching the use of SIGUSR1 and SIGUSR2 and the notify option 
to enable the clean up of temporary files in the event of job abort.

I wrote a simple script:

#!/bin/sh

trap 'echo "Detected USR1";exit 10' 30
trap 'echo "Detected USR2";exit 12' 12

while true
do
  echo "loop " $$
  sleep 2
done

When I run at an Xterm all works as expected.

However, when I run in a qsub with -notify on I get the following in the 
error file:

trap: Command not found.
trap: Command not found.
while: Expression Syntax.

I've tried this for csh and zsh, with similar results for both other 
shells. I must be missing something simple, but a search of GE  mailing 
list archives and the web has drawn nothing.

Thanks,

Tim Bateman


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list