[GE users] Scripts differing between user enviroment and GridEngine environment

Reuti reuti at staff.uni-marburg.de
Tue Apr 12 08:55:00 BST 2005


    [ The following text is in the "ISO-8859-1" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]

Hi,

issuing a signal to a process, is just reaching the process. In SGE the whole 
process group will get the signal (i.e. something like "kill -usr2 -- -1946").

So, the output you got seems ok to me.

Cheers - Reuti


Quoting Ron Chen <ron_chen_123 at yahoo.com>:

> Can you add "trap" without any arugments before the
> while loop, and compare the execution output?
> 
> >From the sh manpage:
> "The trap command has no effect on signals that were
> ignored on entry to the shell. trap without any
> arguments cause it to write a list of signals and
> their associated action to the standard output in a
> format that is..."
> 
> Seems like the signal mask in the SGE environment and
> that in the shell environment is a sightly different.
> 
>  -Ron
> 
> --- Timothy Bateman <timb at cisra.canon.com.au> wrote:
> > So the child process is receiving interrupts that
> > are masked in the non GE 
> > case, and the TERM isn't trapped.
> 
> 
> 
> 		
> __________________________________ 
> Do you Yahoo!? 
> Yahoo! Small Business - Try our new resources site!
> http://smallbusiness.yahoo.com/resources/
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> For additional commands, e-mail: users-help at gridengine.sunsource.net
> 



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list