[GE users] Scripts differing between user enviroment and GridEngine environment

Rayson Ho raysonho at eseenet.com
Tue Apr 12 18:33:31 BST 2005


    [ The following text is in the "iso-8859-1" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]

Timothy, did you use qdel to kill the job??

Try to logon to the node and do a kill by hand and see if the behaviour is
the same. Also...

>From queue_conf(5):
========================================================================
 suspend_method
 resume_method
 terminate_method

 Per  default,  the signals  SIGSTOP,  SIGCONT  and SIGKILL are 
 delivered to the job to perform these actions.
========================================================================

Since SIGKILL can't be masked, may be SGE should first send SIGTERM, wait a
bit, before sending SIGKILL.

I know we can set up a terminate_method to get this behaviour, but sending
SIGTERM before SIGKILL looks more correct to me.

Rayson


>issuing a signal to a process, is just reaching the process. In SGE the
whole 
>process group will get the signal (i.e. something like "kill -usr2 --
-1946").
>
>So, the output you got seems ok to me.
>
>Cheers - Reuti
>
---------------------------------------------------------
Get your FREE E-mail account at http://www.eseenet.com !

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list