[GE users] Solaris 10 init scripts

Andy Schwierskott andy.schwierskott at sun.com
Thu Apr 14 10:28:37 BST 2005


Jonathan,

> The init scripts inst_sge installs in /etc/rc2.d don't seem to work
> properly. On my nodes i need to mount /opt/sge before the daemon can be
> started, so i put that in the init script, but it still doesn't work..
>
> The script works when i run it manually after the system has booted up,
> but it doesn't seem to run during the boot. Did anyone else experience
> this?

Is /opt/sge a NFS mount?

The high number of the SGE start scripot (S95...) should ensure that all
filesystems are mounted whne SGE is started, however I can imagine that the
new svc (Service Management Facility)  method in S10 for startinh the init
scripts could have changed something.

Looking at the svc.startd(1M) man page however I'd assume that the SGE
startup should be started after the network mounts. I'm not yet really
familiar with the svcs(1) command how to dig that out when what services are
started.

Andy

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list