[GE users] Scalapack issues

Arati Kadav aratik at cse.iitk.ac.in
Wed Apr 20 07:21:18 BST 2005


    [ The following text is in the "ISO-8859-1" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]

Hello,
I wanted to run SCALAPACK on my Solaris machines over Grid. I tried the 
following:
I followed the steps mentioned in 
http://www.netlib.org/scalapack/examples/readme.
Except the following changes:
f77 --> g77 in point number 5.

and command number 6 instead of being :

f77 -f -o example1 example1.f scalapack_SUN4SOL2.a \
             blacsF77init_MPI-SUN4SOL2-0.a blacs_MPI-SUN4SOL2-0.a \
             blacsF77init_MPI-SUN4SOL2-0.a blas_SUN4SOL2.a \
             $MPI_ROOT/lib/solaris/ch_p4/libmpi.a -lnsl -lsocket

I used  to set the correxct path of libmpi.a:
/usr/local/bin/mpif77 -o example1 example1.f scalapack_SUN4SOL2.a 
blacsF77init_MPI-SUN4SOL2-0.a blacs_MPI-SUN4SOL2-0.a 
blacsF77init_MPI-SUN4SOL2-0.a blas_SUN4SOL2.a /usr/local/lib/libmpi.a 
-lnsl -lsocket

however I am getting the following error:
Undefined                       first referenced
symbol                             in file
__do_f_out_nv                       scalapack_SUN4SOL2.a(pxerbla.o)
blacs_gridinit__                    /var/tmp/ccM7bYrj.o
__pow_di                            scalapack_SUN4SOL2.a(dlamch.o)
blacs_gridinfo__                    /var/tmp/ccM7bYrj.o
blacs_pinfo__                       /var/tmp/ccM7bYrj.o
__s_wsFe_nv                         scalapack_SUN4SOL2.a(pxerbla.o)
blacs_gridexit__                    /var/tmp/ccM7bYrj.o
__c_conv_i                          scalapack_SUN4SOL2.a(lsame.o)
blacs_get__                         /var/tmp/ccM7bYrj.o
__e_wsfe                            scalapack_SUN4SOL2.a(pxerbla.o)
__s_copy                            scalapack_SUN4SOL2.a(pbdgemm.o)
__s_cmp                             scalapack_SUN4SOL2.a(pdlange.o)
blacs_exit__                        /var/tmp/ccM7bYrj.o
blacs_setup__                       /var/tmp/ccM7bYrj.o
ld: fatal: Symbol referencing errors. No output written to example1
collect2: ld returned 1 exit status
/usr/local/bin/mpif77: No such file or directory

I am not being able to figure out what is missing.

My machine doesnot have f77. I figured out that my problems are because 
of missing f77 as they and g77 append some different number of 
underscores in the file.
Using:
 g77 -fno-second-underscore -o example1 example1.f scalapack_SUN4SOL2.a 
./blacsF77init_MPI-SUN4SOL2-0.a ./blacs_MPI-SUN4SOL2-0.a  
./blacsF77init_MPI-SUN4SOL2-0.a ./blas_SUN4SOL2.a 
blacsCinit_MPI-SUN4SOL2-0.a /usr/local/lib/libmpi.a -lnsl -lsocket 
-lthread -L/usr/local/lib -llammpio -llamf77mpi -lmpi -llam -laio -laio  
-lsocket -lnsl -lthread -lthread -ldl

reduced number of error messages to:
Undefined                       first referenced
 symbol                             in file
__c_conv_i                          scalapack_SUN4SOL2.a(lsame.o)
__e_wsfe                            scalapack_SUN4SOL2.a(pxerbla.o)
__s_copy                            scalapack_SUN4SOL2.a(pbdgemm.o)
__do_f_out_nv                       scalapack_SUN4SOL2.a(pxerbla.o)
__s_cmp                             scalapack_SUN4SOL2.a(pdlange.o)
mpi_init_                           
./blacsF77init_MPI-SUN4SOL2-0.a(blacs_pinfo_.o)
__pow_di                            scalapack_SUN4SOL2.a(dlamch.o)
__s_wsFe_nv                         scalapack_SUN4SOL2.a(pxerbla.o)
ld: fatal: Symbol referencing errors. No output written to example1
collect2: ld returned 1 exit status

However I cannot figure out how to remove these.
Regards,
Arati




---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list