[GE users] your job is not allowed to run in any queue

Amber A. Marsh marsh23 at llnl.gov
Thu Dec 1 22:59:06 GMT 2005


deadlineusers and defaultdepartment, I believe, came configured by default, and
are both empty groups.

user_lists            deadlineusers defaultdepartment
xuser_lists           NONE
==========================


qname                 all.q
hostlist              @allhosts
seq_no                0
load_thresholds       np_load_avg=1.75
suspend_thresholds    NONE
nsuspend              1
suspend_interval      00:05:00
priority              0
min_cpu_interval      00:05:00
processors            UNDEFINED
qtype                 BATCH INTERACTIVE
ckpt_list             NONE
pe_list               make
rerun                 FALSE
slots                 1
tmpdir                /tmp
shell                 /bin/csh
prolog                NONE
epilog                NONE
shell_start_mode      posix_compliant
starter_method        NONE
suspend_method        NONE
resume_method         NONE
terminate_method      NONE
notify                00:00:60
owner_list            NONE
user_lists            deadlineusers defaultdepartment
xuser_lists           NONE
subordinate_list      NONE
complex_values        NONE
projects              NONE
xprojects             NONE
calendar              NONE
initial_state         default
s_rt                  INFINITY
h_rt                  INFINITY
s_cpu                 INFINITY
h_cpu                 INFINITY
s_fsize               INFINITY
h_fsize               INFINITY
s_data                INFINITY
h_data                INFINITY
s_stack               INFINITY
h_stack               INFINITY
s_core                INFINITY
h_core                INFINITY
s_rss                 INFINITY
h_rss                 INFINITY
s_vmem                INFINITY
h_vmem                INFINITY

At 02:48 PM 12/1/2005, you wrote:

      Hi Amber,

      Can you post the output of "qconf -sq all.q" ? In particular are 
      there any entries for:

      user_lists
      xuser_lists

      ... that could be causing unintended access control restrictions to 
      be in place?

      -Chris





      On Dec 1, 2005, at 5:28 PM, Amber A. Marsh wrote:

            We've recently installed SGE 6.0s2snapshot1, and we've
            run into a 
            roadblock. Any job submitted by any user (via qsub)
            receives the 
            following error:
            "Unable to run job: warning: <user> your job is not
            allowed to run 
            in any queue"
            Where <user> is of course the user-name of whomever
            tried to submit 
            the job.  We've tried submitting as both root and normal
            users.

            Clicking on "Why?" under job control lists:
            "scheduling info:                         has no
            permission for queue "all@<host>"
            for each execution host configured. So the jobs just sit
            there 
            indefinitely in the Pending Jobs queue.

            What are we missing? Please let me know what
            configuration 
            information would be of use in diagnosing this issue.

            Thank you,
            --Amber Marsh



            ---------------------------------------------------------------------
            To unsubscribe, e-mail:
            users-unsubscribe at gridengine.sunsource.net
            For additional commands, e-mail:
            users-help at gridengine.sunsource.net



      ---------------------------------------------------------------------
      To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
      For additional commands, e-mail: users-help at gridengine.sunsource.net

--------------------------------------------------------------------- To
unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net For additional
commands, e-mail: users-help at gridengine.sunsource.net



More information about the gridengine-users mailing list