[GE users] PVM w/ SGE

Raymond Chan raychan at ucdavis.edu
Tue Dec 13 19:57:45 GMT 2005


Hi all,

 

I apologize if this has been asked before, but I wasn't able to find
anything specifically that addresses my problem, which seems to be something
really simple I'm missing.  I'm trying to integrate PVM w/ SGE with loose
integration first, then I was going to try tight integration after I get
loose working correctly.  More specifically, I'm trying to run a PVM HMMER
(a bioinformatics app) job, and I am able to successfully use HMMER w/ PVM
standalone w/o any Grid Engine.  I've been following the PVM integration
article from Reuti at
http://gridengine.sunsource.net/howto/pvm-integration/pvm-integration.html

 

I set all the appropriate environment variables for PVM I believe (PVM_ROOT,
PVM_RSH, PVM_ARCH, PVMHOSTFILE, and included the right paths to executables
of HMMER, and so forth in the PVM host file).  This is the script I submit
to SGE via qsub:

 

-----------

#!/bin/bash

 

#$ -N pfam18

#$ -o /home/ray/hmmer/pfam.out

#$ -e /home/ray/hmmer/pfam.err

#$ -m e

#$ -m a

#$ -pe pvm 2

export PATH=$PATH:/apps/HMMER/bin

 

hmmpfam --pvm /frontend/db/hmmer/Pfam/Pfam_ls_bin /home/ray/hmmer/swiss7 >
/home/ray/hmmer/pfam_output

 

--------------

 

In the error file (pfam.err), I always get a  "pvm_spawn: host 1
(compute-0-0.local): hmmpfam-pvm not in path" error.  

 

However, my host file does find this path correctly when I run PVM HMMER
standalone w/o SGE.  I thought this error may mean it's not in my $PATH
environment, so that's why I added the path to the hmmpfam-pvm binary in the
submitted script as well (/apps/HMMER/bin).  Does SGE control of PVM affect
the paths and settings in the PVM host file, so that's why it always gives
me that error?  I apologize that this is also a PVM question as well and I
know I'm emailing the SGE list, but since I only have problems during SGE, I
thought maybe you guys would be more help.  FYI: I'm running this all on a
ROCKS 4.0.0 x86_64 cluster.

 

Thanks in advance for any insight you can give me about this issue I have.

 

-Ray C.

Univ of CA Davis

 

 




More information about the gridengine-users mailing list