[GE users] SGE in shell script problem

Marco Donauer Marco.Donauer at Sun.COM
Thu Dec 15 14:39:44 GMT 2005


    [ The following text is in the "ISO-8859-1" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]

Hi,

please try to source the settings file in your cron command, then your 
environment should be ok
and the qstat should work.

eg: source sge-root/sge-cell/common/settings.csh; /path/to/bash/script

Regards,
Marco

Jon Savian wrote:

>Hi Every1
>
>I am trying to write a bash shell script (not an sge submit script)
>and am trying to get some output from "/path/to/bin/qstat -f" to
>parse.  When i run I run the script myself it has no problem getting
>output.  If I set it up to use cron it will not execute and gives the
>error "please define SGE_ROOT".  Exporting the variable or just
>defining it in the script again,ie. SGE_ROOT=/path/to/gridengine, do
>not work.
>
>Any suggestions?
>
>Jon (the funky homosapien)
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
>For additional commands, e-mail: users-help at gridengine.sunsource.net
>
>  
>

-- 

Marco Donauer            Tel: +49 941 3075-211  (x60211)
Software Engineer        Fax: +49 941 3075-222  (x60222)
Sun Microsystems GmbH
Dr.-Leo-Ritter-Str. 7    mailto:marco.donauer at sun.com
D-93049 Regensburg       http://www.sun.com/gridware


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list