[GE users] trouble with getting SGE 5.3 to work with lam mpi 7.1.1 on RHEL 3

Jan Behrend jbehrend at mpifr-bonn.mpg.de
Thu Dec 22 08:10:35 GMT 2005


    [ The following text is in the "ISO-8859-1" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]

Hi,

try:
mpirun C /home/jon/a.out

Jon Savian wrote:
> I've been trying to set up a lam mpi parellel environment on sge.  I
> followed the instructions here: 
> http://gridengine.sunsource.net/howto/lam-integration/lam-integration.html
> 
> All that went well.  So i download the lam mpi hello world example
> (found here: http://www.lam-mpi.org/tutorials/nd/part1/lab1.c) and
> comipled it.  I try running the program on the cluster frontend and
> sure enough it says "Hello World!" as it should.  When i submit the
> job in SGE i use the following script
> 
> --------------------------------------------
> 
> #!/bin/bash -f
> #$ -cwd
> #$ -V
> #$ -pe lam 6
> #$ -S /bin/bash
> 
> mpirun -C /home/jon/a.out
> 
> -------------------------------------------
> 
> It then produces 4 output files: job.po332, job.o332, job.pe332, job.e332
> 
> -The job.po332 file contains
> 
>    LAM 7.1.1/MPI 2 C++ - Indiana University
> 
> 
>    LAM 7.1.1/MPI 2 C++ - Indiana University
> 
> -The job.o332 file is just blank
> 
> -The job.pe332 contains
> 
>    n-1<9773> ssi:boot:base:linear: booting n0
>    n-1<9773> ssi:boot:base:linear: booting n1
>    n-1<9773> ssi:boot:base:linear: booting n2
>    n-1<9773> ssi:boot:base:linear: finished
>    mkdir: No such file or directory
> 
> -The job.e332 file contains
> 
> -----------------------------------------------------------------------------
> Synopsis:       mpirun [options] <app>
>                 mpirun [options] <where> <program> [<prog args>]
> 
> Description:    Start an MPI application in LAM/MPI.
> 
> Notes:
>                 [options]       Zero or more of the options listed below
>                 <app>           LAM/MPI appschema
>                 <where>         List of LAM nodes and/or CPUs (examples
>                                 below)
> .....
> 
> Is there something i am doing wrong?  Is the "Hello World" supposed to
> go to the job.o332 file?
> 
> Jon
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> For additional commands, e-mail: users-help at gridengine.sunsource.net
> 


-- 
Jan Behrend
Max-Planck-Institut für Radioastronomie
Abteilung für Infrarot-Interferometrie  Tel:   (+49) 228 525 319
Auf dem Hügel 69                        Fax:   (+49) 228 525 411
D-53121 Bonn (Germany)                  jbehrend at mpifr-bonn.mpg.de
                                        http://www.mpifr-bonn.mpg.de

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list