[GE users] failed searching requested shell sge6 u3 drmaa

Fred L Youhanaie fly at anydata.co.uk
Fri Feb 4 17:31:48 GMT 2005


    [ The following text is in the "ISO-8859-1" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]



Ron Chen wrote:
> --- Fred L Youhanaie <fly at anydata.co.uk> wrote:
> 
>>I can't remember seeing anything about shell behavior in the drmaa spec.
> 
> 
> DRMAA by default turns on: "-p 0", "-b yes", "-shell no", "-w e"
> (ref: http://gridengine.sunsource.net/servlets/ReadMsg?msgId=24106&listName=users)
> 

OK, I should have done my homework first, this is also documented in 
drmaa_attributes man page :( But, I was thinking of the DRMAA API spec, 
rather than the sge implementation!

'qsub -b yes -shell no sleeper.sh 5' (with no x perms on sleeper.sh) 
does produce the same result as the drmaa program.

However, trying to pass '-b no' to the drmaa job, either via the 
native_specifications attribute or ~/.sge_request causes the drmaa 
process to segfault!! '-shell yes' is OK, but one needs both options.

If this is not a known problem, I can raise an issue.


Ralf, I think for now you will have to apply 'chmod +x ...' to your 
scripts :-()

Cheers
f.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list