[GE users] Long delay when submitting large jobs

Craig Tierney ctierney at hpti.com
Sat Feb 5 18:09:15 GMT 2005


On Fri, 2005-02-04 at 19:24, Rayson Ho wrote:
> >When qmaster starts up a job, does it talk to each host, one by
> >one, setting up the job information?  The scheduler actually picks
> >the nodes used, correct?  If qmaster is talking to each node,
> >is it done serially or are multiple requests sent out >simultaneously?
> 
> Hi Craig,
> 
> Is the PE tight??
> 
> If it is... would you please check if a non-tight PE job can reproduce the
> problem??

It is loose.  We only schedule 1 job per node, we can then
kill off any processes in the prologue/epilogue.  It is left
over from PBS days, but we still like it because some users have
launching mechanisms that are not mpi, but use multiple nodes.

We are going to have some system time this week.  We are going
to upgrade to 6.0u3, and then I am going to turn debugging on
for the qmaster and see if I can get some more information for
the list.

Craig

> 
> Rayson
> 
> 
> ---------------------------------------------------------
> Get your FREE E-mail account at http://www.eseenet.com !
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
> For additional commands, e-mail: users-help at gridengine.sunsource.net
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list