[GE users] libdrmaa probs on Red Hat & SGE6u3

Rayson Ho raysonho at eseenet.com
Wed Feb 9 20:33:45 GMT 2005


    [ The following text is in the "iso-8859-1" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some special characters may be displayed incorrectly. ]

Did you use the pre-compiled binary??

And can you try the simple C DRMAA programs in $SGE_ROOT/examples/drmaa?

Rayson

>The short of the problem is that jobs are successfully run via qsub, but
>when I try to run a drmaa_init I get back:
>unable to contact qmaster using port 555 on host "bio-e-dev.llnl.gov"
>
>There are a few places the problem could be:
>* first I chose a non-std port for sge_qmaster in /etc/services because
535
>was reserved in there for something else
>* also, I am using my Schedule::DRMAAc module as a wrapper to libdrmaa (
>this is my first compile on Linux with SGE6 ).  I developed
Schedule::DRMAAc
>using SGE sources when 6.0 was beta, and didn't get and opportunity to try
a
>lot of platforms at the time.   However, Schedule::DRMAAc is just a SWIG
>binding to the C library and given that I get an error message like above
>tells me the problem is not likely a bug with my code, but perhaps my
>installation or a bug in drmaa or something else?
>
>What's the easiest way to test the drmaa library?
>
>- Tim Harsch
>
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
>For additional commands, e-mail: users-help at gridengine.sunsource.net
>
>
---------------------------------------------------------
Get your FREE E-mail account at http://www.eseenet.com !

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list