[GE users] setting up mpich2 pe + qrsh

jeroen.m.kleijer at philips.com jeroen.m.kleijer at philips.com
Fri Feb 11 11:26:35 GMT 2005


Hi Reuti,

<loads and loads of explicitives!!!>

This simple check did it.
I followed/adjusted the mpi.template provided in the distribution 
$SGE_ROOT/mpi directory where it is set to false.

Thanks for the patience, the program now seems to work!

Met vriendelijke groeten / Kind regards

Jeroen Kleijer
Unix Systeembeheer
Philips Applied Technologies









Reuti <reuti at staff.uni-marburg.de>
2005-02-11 12:09 PM
Please respond to users
 
        To:     users at gridengine.sunsource.net
        cc:     (bcc: Jeroen M. Kleijer/EHV/CFT/PHILIPS)
        Subject:        Re: [GE users] setting up mpich2 pe + qrsh
        Classification: 




Hi Jeroen,

Quoting jeroen.m.kleijer at philips.com:

<snip> 
> I checked and the $TMPDIR (which is /volumes/scratch/<jobid>.batch.q) is 

> created on the starting host of the job (usually the nlcftcs14). This 
> directory doesn't get created on the other nodes (nlcftcs12 or 13), 
> neither by SGE itself nor the startmpi.sh script.
> I'll comment out the mkdir entry.
> 
> As for MPICH2, this /cadappl directory is indeed shared via NFS and 
> accessible on all systems, so I'm a bit at a loss as to where the 
message
> "error: executing task of job <jobid> failed:"
> with nothing to go along with. It seems to be related to qrsh but I can 
> run the command with 'regular' rsh just fine.

observing this both: did you set "control_slaves    TRUE" in the PE 
definition?

Cheers - Reuti

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net





More information about the gridengine-users mailing list