[GE users] qsub + -S parameter

jeroen.m.kleijer at philips.com jeroen.m.kleijer at philips.com
Fri Feb 18 15:18:30 GMT 2005


Hi all,

I'm trying to get an application (Abaqus) configured to use the SGE 
submission mechanism.
This application basically takes an input file, creates a <job>.com file 
which is nothing more than a python script which needs to be submitted.
To run this script locally you would basically enter 'abaqus python 
<job>.com'.

I though it would be possible to use the qsub command for this to do the 
following:
qsub -V -cwd -q batch.q <job>.com
This fails because the python-script lacks the usual first line 
'#!<path-to-abaqus-installdir>/abaqus python' so to Unix this is nothing 
more than some garbled command/data which needs to be interpreted by the 
default shell.

I thought I could solve this by doing:
qsub -V -cwd -q batch.q -S "<path-to-abaqus-installdir>/abaqus python" 
<job>.com
but this fails as well.

My error messages tell me that it is still being interpreted by the 
default shell (Korn shell in my case) and I've even tried:
qsub -V -cwd -q batch.q -S "/bin/ksh -c <path-to-abaqus-installdir>/abaqus 
python" <job>.com
but even this fails with the same error messages.

I don't really want to use the qrsh or qsh solution (which would be 
obvious) but I have no idea why the -S solution fails. 
Any ideas anyone?

Met vriendelijke groeten / Kind regards

Jeroen Kleijer
Unix Systeembeheer
Philips Applied Technologies



More information about the gridengine-users mailing list