[GE users] Job Failure Deletes Local Spool Directory

Roland Dittel Roland.Dittel at Sun.COM
Thu Feb 24 15:26:21 GMT 2005


    [ The following text is in the "UTF-8" character set. ]
    [ Your display is set for the "ISO-8859-10" character set.  ]
    [ Some characters may be displayed incorrectly. ]

Hi Dan,

we have changed this behavior in our main trunk. In future you are able 
to change the execd_spool_dir but the change will only be effective 
after a restart of the execd's.

In 60u3 the only way to change the global execd_spool_dir is by 
exploiting a bug (which is fixed in maintrunk). You can change the 
execd_spool_dir value in two steps. The first step is to remove with 
qconf -mconf the whole line and save the new configuration. In the 
second step you are able to add the the attribute with a new value.

bye
Roland


Dan Gruhn wrote:
> Harald,
> 
> Thanks, this will work for each individual host.  Perhaps I am being 
> greedy, but do you know how I can change the global parameter?  Then I 
> will just remove this from the execution hosts.
> 
> I've tried shutting down all of the execution hosts and even the 
> scheduler.  However, I still get the error message:
> 
> "Changing parameter "execd_spool_dir" only supported in a shut-down 
> cluster."
> 
> How can one change this without having the QMaster running?
> 
> Dan
> 
> On Wed, 2005-02-23 at 09:38, Harald Pollinger wrote:
> 
>>/With a running QMaster:
>>
>>qconf -sconf <host>
>>
>>Mark and copy the displayed values.
>>
>>qconf -dconf <host>
>>qconf -aconf <host>
>>
>>Paste values to the now opening editor, change "execd_spool_dir", save
>>and quit editor.
>>Then, restart the sge_execd.
>>
>>
>>Regards,
>>Harald/
>>
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list