[GE users] rcmd: socket: Cannot assign requested address

Andreas Haas Andreas.Haas at Sun.COM
Tue Jan 18 10:49:30 GMT 2005


On Mon, 17 Jan 2005, John_Tai wrote:

> I did shutdown the qmaster daemon, and that is when I couldn't restart it at all:
>
> root at dsfileserver: /etc/init.d # ./sgemaster
>    starting sge_qmaster
>
> sge_qmaster didn't start!
> Please check the messages file
>
>    starting sge_schedd
> error: getting configuration: unable to contact qmaster using port 5098 on host "dsfileserver"
> can't get configuration from qmaster -- waiting ...
> can't get configuration from qmaster -- waiting ...
> can't get configuration from qmaster -- waiting ...
> error: can't get configuration from qmaster -- backgrounding
>
> Messages file had this:
>
> 01/13/2005 15:39:20|qmaster|dsfileserver|E|couldn't set rpc server in database environment: (-30993) DB_NOSERVER: Fatal error, no RPC server
> 01/13/2005 15:39:20|qmaster|dsfileserver|E|startup of rule "default rule" in context "berkeleydb spooling" failed
> 01/13/2005 15:39:20|qmaster|dsfileserver|C|setup failed
>
> So I tried to restart the BDB, but the daemon occupied 20-30% of the CPU, which I had never seen before.

I assume you verified all master daemons qmaster, scheduler and
berkeley_db_svc were shut down orderly before you tried to restart.
Is this correct?

> So I assumed the BDB daemon was hanging (where are the BDB messages?).

With current 6.0 berkeley_db_svc logging is not yet used. We have to
change this. I explain the workaround with the related issue

   http://gridengine.sunsource.net/issues/show_bug.cgi?id=1418

Andreas

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe at gridengine.sunsource.net
For additional commands, e-mail: users-help at gridengine.sunsource.net




More information about the gridengine-users mailing list